S-10 Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
I have a 98 s10 4.3 with 5 speed. I bought the truck new and put about 235000 miles on it with pretty much no issues. I bought a Versa in 2014 for better gas mileage and parked it for about six months. Since it had been sitting I decided to sell to my brother. He called one day saying something about lights on on the dash. I didn’t think anything of it because he kept driving it. I have recently got it back and have found out what he was talking about. The security light stays on while running. It starts fine and runs fine. Sometimes the battery light, abs light, low fuel, temp gauge goes out and fuel gauge goes out. The brakes do no work right when the abs light is on. I have a new battery. Also when when this happens the security light stays on constantly even with key removed. Has anyone experienced this issue?
 

·
time to get cereal
Joined
·
2,287 Posts
If the security light is on and the vehicle still starts, it means that a fault occured in the security circuit while the engine was running. Either something's been munching on your wire harness, or you have bad connection(s) somewhere (everywhere?)
 

·
Registered
Joined
·
19 Posts
Discussion Starter #4
Yes, I am going to take a closer look this weekend. He had an issue with dead batteries but was buying really cheap ones. Not sure if that is related. The security light came on one time but I was able to reset.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #5
I have been searching post and seen similar issues. I was thinking possibly battery cables. I believe the ignition switch was the the issue in another post. Loose ground somewhere. I did have a system hooked up and he thought that was draining the battery. It has been unhooked.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #6
If the security light is on and the vehicle still starts, it means that a fault occured in the security circuit while the engine was running. Either something's been munching on your wire harness, or you have bad connection(s) somewhere (everywhere?)
 

·
Registered
Joined
·
19 Posts
Discussion Starter #7
If the security light is on and the vehicle still starts, it means that a fault occured in the security circuit while the engine was running. Either something's been munching on your wire harness, or you have bad connection(s) somewhere (everywhere?)
Could a worn out key cause the security light to come on. My truck is a base model. I don’t have a key fob or anything.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #11
No sign of anything chewed. I replaced the ignition switch and had a new key made. I have a brand new red top battery. Still the same issue. The parts guy at dealership suggested the switch. He also said could be lock cylinder housing. He said those two things could cause the security light and the other issues. Think I may try lock cylinder housing. Any ideas??
 

·
Registered
Joined
·
19 Posts
Discussion Starter #12
Also when the issue happens the security light is on constant even when turned off. Temp guage is out fuel gage is out battery light is on abs light is on. Bright light indicator doesn’t work and parking brake light indicator doesn’t work. When everything goes back to working the batt light is still on but if you turn off and restart everything is back to working except the security light is on constant but will turn off when truck is turned off.
 
1 - 13 of 13 Posts
Top