S-10 Forum banner
1 - 20 of 33 Posts

·
Registered
Joined
·
2,461 Posts
Discussion Starter · #1 ·
hey guys i finally picked up my 91 4.3l jimmy today and realized the speedo does not work could it be a fuse or the sensor or what would your guys idea I need it fixed asap
 

·
ASE certified MasterTech
Joined
·
8,695 Posts
Check the 15A brake fuse....
Check the DRAC to see if it is connected with the harness.

Does your cruise work?
Any VSS codes(DTC #24)?
 

·
Registered
Joined
·
2,461 Posts
Discussion Starter · #3 ·
Check the 15A brake fuse....
Check the DRAC to see if it is connected with the harness.

Does your cruise work?
Any VSS codes(DTC #24)?
brake fues really

ya i checked the drac it was pluged in

doesnt have cruise

all i have is the intermitent ses light but its coming on less and less now that ive drove it been sitting for 3 years
 

·
Registered
Joined
·
2,461 Posts
Discussion Starter · #4 ·
so i checked the fues its good
 

·
ASE certified MasterTech
Joined
·
8,695 Posts
Ya.........brake fuse, it's what the DRAC gets it power from.........

OK, then you need to check the pulses coming from/going to the DRAC, or lack there of.
CHeck the signal from the DRAC, the Lt Blu/BLK wire that goes to the back of the cluster, pin #14. You will have to place the vehicle on stands and run the truck in gear to get a reading. Speed sensor to DRAC module is two wires, Lt Grn/Blk and PPL/Wht, these are the inputs from the VSS, these will show a pulsing AC voltage.

Let me know if you need any clarification during this process.
 

·
Registered
Joined
·
2,461 Posts
Discussion Starter · #6 ·
ok thanks man how would i check the pulses with a test light?
 

·
ASE certified MasterTech
Joined
·
8,695 Posts
You really need a DVOM to check for varying voltage, kinda hard to do with a test light.
 

·
Registered
Joined
·
2,461 Posts
Discussion Starter · #8 ·
ok any long form to the dvom or just dvom i donno much about this newer electronic stuff
 

·
ASE certified MasterTech
Joined
·
8,695 Posts
Digital Volt Ohm Meter
 

·
Registered
Joined
·
2,461 Posts
Discussion Starter · #10 ·
hmmm ok i know i have a volts ohm meter but its not digi would it work or not
 

·
Registered
Joined
·
2,461 Posts
Discussion Starter · #12 ·
ok thanks but i think ive narrowed it down to the speed sensor as my service engine likes comes on when i go about 20 km/h (code 24)
 

·
ASE certified MasterTech
Joined
·
8,695 Posts
Replacing the VSS will not fix an open in the circuit if the open is somewhere between the VSS and the DRAC...........
 

·
Registered
Joined
·
2,461 Posts
Discussion Starter · #14 ·
ya i know that i looked at the wires all the way to the firewall i didnt see anything wrong they where all in the black wire casing stuff i dont have a dvom to test the sensor im gonna see im my grandfather has one but otherwise i donno
 

·
Registered
Joined
·
2,461 Posts
Discussion Starter · #15 ·

·
ASE certified MasterTech
Joined
·
8,695 Posts
ya i know that i looked at the wires all the way to the firewall i didnt see anything wrong they where all in the black wire casing stuff i dont have a dvom to test the sensor im gonna see im my grandfather has one but otherwise i donno
Looks can be deceiving, example:
Had a car(Jeep Cherokee) come in the shop, complaint was the power windows wouldn't work, but once you opened the door up they would work. The problem was in the wiring that runs through the rubber boot on the frame portion of the door. All the opening and closing broke a wire, but once the door was open it would make contact and close the circuit.
Is this your problem? Doubtful, but still something to keep in mind.
You need to verify which one you need by looking at yours first, because I see two different kinds for that model year, I am unsure if one is for auto and the other is for a manual. But the one I replaced on my 91 5 speed was the type that was held in by one bolt.
 

·
Registered
Joined
·
2,461 Posts
Discussion Starter · #17 ·
ya man i understand about broken wires i just really dont wanna start screwing with the wiring i honestly know enough for basic things like stereos alts starters all that stuff and more but when it comes to computer stuff im at a loss and honestly think its just the sensor as like you said it's more common then the wiring.

mine has the one that threads into the tail housing yours might be different if its two wheel drive i donno.

how much roughly did you pay for yours cuz they have different ones for different prices that both look the same and am not sure if theres a difference besides quality
 

·
Registered
Joined
·
1,854 Posts
Replacing the VSS will not fix an open in the circuit if the open is somewhere between the VSS and the DRAC...........
Dat is true ja.


Try swapping out the DRAC. That's next on my list of stuff to try with my VSS problems. Failing that(known working drac swap) I'm just going to rewire it.

Edit. This is the VSS sensor on my 91 4.3 4x4:
 

·
Registered
Joined
·
2,461 Posts
Discussion Starter · #19 ·
That the one man um just a quick question could someone clarify what a drac is I'm guessing it has something to do with the computer
 

·
ASE certified MasterTech
Joined
·
8,695 Posts
The DRAC is a Digital Ratio Adapter Controller, basically it changes the AC pulse from the VSS into a usable voltage that the speedo and ECM can then use. So many pulses per mile etc..

Ya, That's why I told ya to make sure you get the right VSS, the one on a 2wd is in the tail shaft Vs. that one in the transfer case.

I have like 5 extra DRAC's laying around if you or anyone is needing one. I can give you the diagnostic trouble tree to verify the DRAC is bad if you want renswic.
 
1 - 20 of 33 Posts
Top