S-10 Forum banner
1 - 11 of 11 Posts

·
Big Wheels
Joined
·
5 Posts
Discussion Starter · #1 ·
I just put a 3/4 drop on my 03 sonoma ext cab and the drivetrain "vibrates" around 50-60 mph.

I installed the rear blocks with the slope angled down towards the front and the high side to the back.

Still vibrates!?! what is the problem?
Any suggestions on how to fix this?

If i cant find a solution i'll have to change back to stock.

thanks in advance
 

·
choppin on twankies!
Joined
·
656 Posts
if u truck is an extended cab i think u need to get a carrier bearing spacer or something...
 

·
Hates 'know-it-alls'
Joined
·
26,065 Posts
Yeah I would get those u joints checked out pretty quick. Even if your truck is the extended cab, as long as you used the angled blocks then you shouldn't have to worry about a carrier bearing spacer. I did a 3/4 drop on my truck and didn't have to worry about that spacer, also I didn't use angled blocks even though you are supposed to. My buddy lowered the rear with 3" leaves and 4" angled blocks and he's been driving it over a year without any drivetrain problems. He might be getting lucky!!! I would check those u joints out though, you don't want to shuck that driveshaft while going down the highway.
 

·
EX-Minitrucker
Joined
·
3,978 Posts
More than likely it's the carrier bearing spacer that you need to get. Most ext cabs need it specially with trucks in the year range yours is. Just search for it here on the forum and i'm sure you will find a link to a guy that makes the spacer out of billet aluminum. That would be the best thing IMO.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top