S-10 Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
498 Posts
Discussion Starter · #1 ·
i have a 97 sonoma ever since i bought it every once in a while the SES light comes on and later shuts off. comes up as random misfire. was told to do a tune up. started with new plugs and wires in the spring. light still on, so last Sunday i replaced the dis coil packs and now yesterday light come back on. when to auto zone and had them scan it again and its still random misfire.
dosn't make sense why its still doing it. any ideas/??
 

·
SlammedSonoma96
Joined
·
904 Posts
Did you change the wires? A faulty fuel injector, can cause random misfire. A bad cam sensor, usually will not let the truck run, but it is possible to run, and have a misfire.
 

·
BLU BALLER
Joined
·
143 Posts
I'd pop off the ignition control module under the coil packs and have it tested. I know oreillys does it. Just make sure to have them test it about 4 times in a row, so it gets heated up. Usually when this goes bad you will have no spark issues, but it could be intermediate.
 

·
Registered
Joined
·
498 Posts
Discussion Starter · #5 ·
I'd pop off the ignition control module under the coil packs and have it tested. I know oreillys does it. Just make sure to have them test it about 4 times in a row, so it gets heated up. Usually when this goes bad you will have no spark issues, but it could be intermediate.
sounds like a good possibility but with it being a random misfire theirs a good chance that it my not show up in a test. also its my only vehicle that i drive to school and work every day. so don't have time to take it off get to o reillys test it then buy then order a new one and so on...
 

·
piss and vinegar
Joined
·
219 Posts
could be anything the crank sensor is seeing as a fluctuation in rpm. could be a bad ground, or even timing chain. the possibilities are pretty wide for a p0300 code that is intermittent.
 

·
Ford guy stuck w/ chebby
Joined
·
3,117 Posts
gotta love these engines. Good luck and keep us posted as to what the results of this code is. Seriously man. We are ALL in your corner on this.. probably Government Motors too.. :D
 

·
Registered
Joined
·
498 Posts
Discussion Starter · #9 ·
obd-codes.com says it could be

Faulty spark plugs or wires
Faulty coil (pack)
Faulty oxygen sensor(s)
Faulty fuel injector(s)
Burned exhaust valve
Faulty catalytic converter(s)
Stuck/blocked EGR valve / passages
Faulty camshaft position sensor
Defective computer

that just crazy

we don"t have egr valves on 94-97 do we?
 
1 - 10 of 10 Posts
Top