S-10 Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I just bought a 2001 s10, and the wire from the abs pump to the module is detached and looks like it burned away, if I hold the wire up to the pump it arch’s (it’s now taped and the battery is dead anyway) but before I install the new pump and module I want to see if anyone knows if an electrical problem outside of the pump could have caused this, and just do it again on new parts.
Motor vehicle Automotive exterior Bumper Automotive fuel system Automotive tire

Automotive tire Motor vehicle Wood Automotive exterior Bumper
 

·
Registered
Joined
·
104 Posts
I just bought a 2001 s10, and the wire from the abs pump to the module is detached and looks like it burned away, if I hold the wire up to the pump it arch’s (it’s now taped and the battery is dead anyway) but before I install the new pump and module I want to see if anyone knows if an electrical problem outside of the pump could have caused this, and just do it again on new parts. View attachment 365467
View attachment 365466
before putting new motor and ABS module on, I'd verify the integrity on the inbound/incoming wiring on the ABS module just to be sure bad wiring wasn't also the original cause for the motor failure...see pics below...check the inbound wiring @ connector "A" in my pic-only one of those wires should grnd...and check inbound wire for pin A1 on connector "B" in my 2nd pic-that should only have + voltage, no grnd out-test both w/key on and a reliable 12V battery supply.


Automotive lighting Font Circuit component Auto part Circle


Font Rectangle Screenshot Parallel Number
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
before putting new motor and ABS module on, I'd verify the integrity on the inbound/incoming wiring on the ABS module just to be sure bad wiring wasn't also the original cause for the motor failure...see pics below...check the inbound wiring @ connector "A" in my pic-only one of those wires should grnd...and check inbound wire for pin A1 on connector "B" in my 2nd pic-that should only have + voltage, no grnd out-test both w/key on and a reliable 12V battery supply.


View attachment 365487

View attachment 365488
Will do, thanks. 👍🏻
 

·
Registered
Joined
·
25 Posts
Years ago I just deleted my '94 ABS module and replaced with steel lines where needed. ABS is one of the most dangerous things on these early 90's cars/trucks as they malfinction from time to time...some times with pedal going to floor.
 
1 - 6 of 6 Posts
Top