S-10 Forum banner
1 - 8 of 8 Posts

·
Been there Done it
Joined
·
13,194 Posts
How can the DBW function w/o a TAC.
Gas pedal is a sensor, that feeds to a TAC Module (Throttle Actuator Control) The TAC module monitors the gas pedal sensor, then commands the throttle body motor to set the desired throttle setting.
What number PCM are you using? 6242?
 

·
Been there Done it
Joined
·
13,194 Posts
Better as @Harley on that. I thought there was more than one model TAC. If you pull one yourself at a yard try to get the connectors and as much harness as possible.
 

·
Been there Done it
Joined
·
13,194 Posts
I suspect ignition 1 is from ENG 1 fuse.
Do you have the ground and brake pedal position (12V) wires connected to the TAC?
Click pic to see it larger.
352216
 

·
Been there Done it
Joined
·
13,194 Posts
Before you convert over to DBC have you tried a DBW reset? When I first hooked my DBW up it would only idle and stall. I found I had a sensor 5v and lo reference switched at the pedal. After I corrected them it still did the same thing.
On some obscure RV site while doing research for my issue I found mention of a DBW reset procedure. You turn the key on, engine off and slowly cycle the pedal all the way 3 times then shut the key off. Next time I started it, it fired right up and the throttle worked. Might have been a fluke, but it worked.
What happened after that you don't want to hear. I should have the replacement engine going soon. I got it bolted in today. But at least my DBW works.
 

·
Been there Done it
Joined
·
13,194 Posts
Us old guys have been around long enough to know that's how you get things done. Just keep plugging away, you'll get it figured out.
 

·
Been there Done it
Joined
·
13,194 Posts
Are you sure your brake pedal position switch is getting 12V to the PCM and TAC when you have your foot off the brake? Neither will function properly with out that 12V input.
 

·
Been there Done it
Joined
·
13,194 Posts
If you have a 4L80E connector some how, those used 2 less wires. Could be your issue.
Notice on the wiring diagram that a couple pins use different locations also.
Click the pic to see it bigger
 
  • Like
Reactions: Harley

·
Been there Done it
Joined
·
13,194 Posts
I believe those are the correct ones. You should pull one of yours to compare to the pic.
Here's an endless discussion on swapping a 4l60E and a 4l80E. Of course it's written from the point of view for someone wanting to swap to the HD trans, but everything you could possibly want to ever know about switching their wiring is in it somewhere.
I stopped reading on post #145. Ignore any reference to a input speed sensor. The 4l60e doesn't have or use one.
 
1 - 8 of 8 Posts
Top