S-10 Forum banner
1 - 8 of 8 Posts

Registered
1994 S10 LS 4X2 with a 4.3 Liter V6 VIN Z
Joined
3 Posts
Discussion Starter · #1 ·
I bought my 1994 s10 with a 4.3 liter v6 vin z, a couple of months ago. I did a coolant flush as the previous coolant was old and dirty. A week after flushing the coolant, it started leaking. I could never figure out where it was leaking from until a month ago. Every time I turned the s10 off, it would leak from the water pump. So I tried a mixture of different stop leaks. None of them worked. So I was driving home, and the car overheated. I pulled into a gas station, and filled the cooling system with distilled water to get me home. When I got home, I noticed it leaked not as much. So I was filling it with distilled water as coolant was expensive to keep using. Then it stopped leaking. After it stopped leaking, I drained the radiator and put coolant in it. Then it started leaking again. So I filled it back up with distilled water, and the leak stops. So I am perplexed as to why my s10 will not leak with distilled water, but leaks when I try and put coolant in it.
Sorry for the long post,
Gavin
 

B4U Task Force Admin
Joined
30,723 Posts
You found the problem but didn't fix it. Your water pump is bad. You'll need to flush the system again to get the stop leak out....don't do that again.. 馃槀 Don't know why it doesn't leak with just water...doesn't matter. You can't/shouldn't run around with plain water in the system.
 
  • Like
Reactions: aitch

Registered
1994 S10 LS 4X2 with a 4.3 Liter V6 VIN Z
Joined
3 Posts
Discussion Starter · #3 ·
You found the problem but didn't fix it. Your water pump is bad. You'll need to flush the system again to get the stop leak out....don't do that again.. 馃槀 Don't know why it doesn't leak with just water...doesn't matter. You can't/shouldn't run around with plain water in the system.
It's not running with full distilled water. I put antifreeze in the water to make sure the water doesn't freeze. And I was also told by a mechanic to try and use stop leak before I take it in. I have a new water pump, just awaiting a good time to replace it. It's been bad weather for the past couple weeks.
 

Registered
2003 Sonoma SLS ext. cab 4.3L / 4x4
Joined
572 Posts
It's not running with full distilled water. I put antifreeze in the water to make sure the water doesn't freeze. And I was also told by a mechanic to try and use stop leak before I take it in. I have a new water pump, just awaiting a good time to replace it. It's been bad weather for the past couple weeks.
I wouldn't return to that mechanic for any further advice (or repairs).
 
1 - 8 of 8 Posts
Top