S-10 Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
145 Posts
Discussion Starter #1
it says bank 2 sensor 1 but i dont know what o2 sensor that is... says P0155 - Heated Oxygen Sensor Heater Circuit (bank 2, sensor 1)
 

·
Registered
Joined
·
5,065 Posts
Bank one would be the same side a cylinder one and sensor one would be the first one. Right side, first sensor
 

·
Registered
Joined
·
145 Posts
Discussion Starter #3
thanks. i never knew which was bank 1 and bank 2. i got that fixed but my coiled ended up being burned up so i replaced it but the plug in part is still burned :( truck was supposed to go for the new hood tomorrow..so much for that.
 

·
Registered
Joined
·
5,065 Posts
You can get the new pictail for that. I just replaced the one in my mom's truck because I was having trouble with ignition and did not like the way the harness pulled the connector so sharply. It was around $30 for a ac delco one though.
 

·
Registered
Joined
·
145 Posts
Discussion Starter #5
where did you pick it up at? is it the whole 3 prong plug or just the inside prong? i need to find one asap tomorrow after work
 

·
Registered
Joined
·
5,065 Posts
I got it through my brothers work and it comes from an oe parts supplier. The dealer should have it or maybe napa can get it. The one I got was the plastic plug and about 12 inches of wire. (all white) There used to be AC Delco parts houses around here that would have them. I don't know what you got in you area.
 

·
Registered
Joined
·
145 Posts
Discussion Starter #7
i got the plus from an auto parts store and it didnt fit. i was able to use male (because of the small openings in the end) and they fit right over the male prongs in the coil tightly. i crimped em on and heat shrinked em, then wrapped em all tight with tape. i know its not perfect but it started first try, with no problems. its currently getting my 2.5" cowl hood two tone to match blue and silver bottom :)
 

·
Registered
Joined
·
5,065 Posts
You should be able to find on at a GM parts online catalog maybe. I tried to look For the package but its long gone so I have no P/N. Are your wires burned or just the plug melted? I have the old plug off mine I can send you. I suspected it may have been shorted because of a tight bend in the wires but it turned out to be the module was bad.
And the cowl hoods are cool. I like them. I need to get one for my mom's 84. It will also help with clearence of the ac compressor.
 

·
Registered
Joined
·
145 Posts
Discussion Starter #9
i got it fixed using terminals, no plug in. not sure if your plug would be the same as mine, could you maybe get a pic of it? just from the side or something, i would recognize it, thanks
 
1 - 9 of 9 Posts
Top