S-10 Forum banner
1 - 6 of 6 Posts

·
Ole skule VW nut
Joined
·
378 Posts
Discussion Starter · #1 ·
Okay, while driving, or sometimes accelerating, I will feel the 4cyl beast chug then continue running smooth, or chug then start chugging so hard I can't accelerate any more and have to pull over and let it idle out. Usually after that, the check engine light comes on. It goes off on it own in about a day, but I can't figure out what causes the hesitation, and it turns off before I can have it read. Fuel filter or sensor maybe?

TIA
 

·
Ole skule VW nut
Joined
·
378 Posts
Discussion Starter · #3 ·
Ahh... did not know that. I'll see about having it looked at tomorrow. I don't think my local Vato-Zone reads engine lights. I know they sell indigo windshield squirters, but I dunno if they actually do any real work. :rolleyes:
 

·
Registered
Joined
·
2,305 Posts
My 2000, one night started running really bad. Every time I would hit the gas it would almost die. If I took my foot off the gas it would run fine and would even start accelerating. I had to shift to N at a stoplight because I was having to stand on the brakes then drop in D and hear it slam into gear and take off then shut off the engine when I pulled into my drive way. Next morning it ran fine, I was guessing TPS because of how it was almost doing the opposite of the throttle but I called autozone, poop boys, and advanced and none of them carried a TPS. This was like 3 months ago and its been fine since.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top