S-10 Forum banner
1 - 6 of 6 Posts

·
registered loser
Joined
·
296 Posts
Discussion Starter · #1 ·
on saturday I put a Magnaflow universal cat on my truck (see sig) to replace the clogged one that was on there. I filled the tank, and then drove home and let the truck sit for the afternoon with the battery unplugged to reset the computer. I have driven 100kms (about 60 miles)since then and I have gone through almost half a tank. I was never getting great mileage and I understand that any mod that gives you more power can lead to heavy foot syndrome, but this is excessive, like a 50% drop in mileage.

I'm paying the equivalent of 5 bucks a gallon up here in Canada and I can't afford to keep this little truck on the road at 7mpg or whatever the hell i'm getting
 

·
registered loser
Joined
·
296 Posts
Discussion Starter · #3 ·
how long does the computer take to relearn? its been reset three times in the last 10 days or so for various reasons.
 

·
registered loser
Joined
·
296 Posts
Discussion Starter · #5 ·
Is it possible that the decreased backpressure means that the engine is not running as hot and therefore never going in to closed loop mode? I didn't replace the o2 sensor but maybe I should replace it with a heated sensor... if those exist for my make/model year
 

·
Registered
Joined
·
274 Posts
it may be the computer, i have run mine with the cutout open for an entire tank and still managed to get 11.5 or so mpg... with it closed i get around 15-17
 
1 - 6 of 6 Posts
Top