S-10 Forum banner

1 - 7 of 7 Posts

·
twisted like a dreadlock
Joined
·
111 Posts
Discussion Starter #1
i just changed the cpi unit, nut kit,gasket,sparkplugs and oil on my truck.Now I smell a burning oil type smell whenever I get out of my truck.It didn't smell before i changed that stuff.I didn't spill oil anywhere and my truck dousn't have any leaks.The truck run's great now that i changed those things i just can't figure out where the smell is coming from.Any ideas?
 

·
bitch
Joined
·
7,884 Posts
since you did all the work it could just be any residue burning off the engine from working on it. how long have you ran it after you did the work? sometimes it takes a little while to burn off. or you can clean the engine really good and run it then.
 

·
twisted like a dreadlock
Joined
·
111 Posts
Discussion Starter #3
I did it on wednesday so it's been a couple of day's.
 

·
bitch
Joined
·
7,884 Posts
sure no oil is leaking? some poeple come into the shop sayin they smell oil burning when their valves covers are leaking right onto the exhaust manifold.
 

·
twisted like a dreadlock
Joined
·
111 Posts
Discussion Starter #5
I'm pretty sure thers no leak I looked over the whole engine plus it didn't smell at all before i did the changes.The only thing different is I put in mobil 1 instead of a synthetic blend i was using.
 

·
Clean N' Dark
Joined
·
1,921 Posts
might have a new seal leak.

I would definitely check for a new leak.
 

·
Kramerica Industries
Joined
·
342 Posts
Full synthetic oil is thinner than 'real' oil or even a blend, thus areas which would not leak when using a blend can start to leak when the thinner oil is used.
 
1 - 7 of 7 Posts
Top