S-10 Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
287 Posts
Discussion Starter · #1 ·
1996 Sonoma 2.2L MT w/ cruise & tilt

Do you have any brand suggestions for a Multi-Function Switch (column turn, headlamp, cruise, wiper/washer)? The correct GM / ACDelco 26100985 switch + stalk is $200+. Aftermarket units on Rock Auto range from ~$46-119 + tax + SH.

Extra info for troubleshooters. Instrument panel right turn signal indicator lights when it should not, but actual exterior lamps operate correctly. Irritating, but not critical. However, wiring diagram indicates, absent some weird, wiring/connector short, the only likely cause is the multi-function switch. It appears I can verify with a continuity/resistance check across the column side of the disconnected C206 Steering Column Harness connector, specifically cavities A2 (PPL) and A6 (DK BLU). So, I will do that before ordering.
 

·
time to get cereal
Joined
·
5,806 Posts
The last part is probably a bad connection at the harness connector, those clusters a junk. Try reseating it a couple times, make sure the stupid film circuit board goes in correctly.
 

·
Registered
Joined
·
287 Posts
Discussion Starter · #3 ·
The last part is probably a bad connection at the harness connector, those clusters a junk. Try reseating it a couple times, make sure the stupid film circuit board goes in correctly.
Thanks. I will check that if the column connector check does not show a stuck/shorted contact in the multi-function switch. The installed tach instrument cluster / panel is not the original, and I cleaned and checked the connections before installation. Do not know if you recall; I wanted to buy your tach panel but you were waiting on some other potential buyer. The original non-tach panel did the same thing. This is not critical, as evidenced by me just checking a schematic yesterday even though I noticed the problem July 2020 when I bought the truck. I am slowly working my way through the long list of “problems” to be expected with a 25 year old vehicle. If it is the switch, not certain it is worth fixing at this time. Reviews indicate the aftermarket switches are not very reliable.
 

·
Registered
Joined
·
287 Posts
Discussion Starter · #4 ·
Providing follow up in case someone uses the search function and reads this thread. Would not want my silly mistake to mislead them. Multifunction switch is fine. Sloppy, rushed troubleshooting on my part. Failed to notice RH Front Side Marker Lamp and RH Front Park & Turn Signal Lamp were not operating properly. One of the 2 – filaments in the Park & Turn Lamp bulb was open, leading to voltage being dropped over the IP RH Turn Lamp when RH Turn Signal switch was not engaged, but Headlamp Switch was in Headlights or Park. Suspect many or most would not have even needed to look at a wiring diagram, and simply would have known to look at the exterior lamps.
 
1 - 5 of 5 Posts
Top