S-10 Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1 (Edited by Moderator)
I am bringing my dad's 1991 s10 back to life from boxes. He just passed and I'm hoping to restore to semi newish, The motor was shot and a used replacement motor was purchased. That's when he stopped. I have installed the motor and I'm working to get the wiring and vacuum all correct. In addition, I have 2 brackets that are a mystery to me. That is a bit embarrassing but it does not seem intuitive. I have included 2 pics of the brackets and a pic of the 3 wire connectors that are also a mystery. I purchased the "Chevrolet 1991 Light truck Service Manual" -- which covers "S models". I find the book to be disappointing. Perhaps there is a better manual I can purchase. I will need a vacuum diagram in the near future as well. So, if anyone has insight on my pics, I will be greatly appreciated. Also, If you know of a better source for wiring and vacuum for this truck please fill me in. I appreciate you folks that take the time to answer people like me. Perhaps I will know enough someday to jump in. Blessings!

Bill

IMG_6637.JPG IMG_6638.JPG IMG_6639.JPG IMG_6637.JPG IMG_6638.JPG IMG_6639.JPG
IMG_6637.JPG
IMG_6638.JPG
IMG_6639.JPG
 

·
B4U Task Force Admin
Joined
·
28,443 Posts
Engine size would help.
 

·
time to get cereal
Joined
·
4,970 Posts
I didn't know bill laswell was into S10s...
 

·
Been there Done it
Joined
·
10,984 Posts

·
Awww..you ain't got shit!
Joined
·
3,506 Posts
These are both for the alternator I think. The one on the right is the one that is often left off. Without it, it puts a lot of stress on the alternator. The one on the right kind of stands up behind it to support it. The other I cannot recall at this moment.

Deathphoenix99's account has some good wiring diagrams. Some of those plugs don't go to anything adn they are simply for testing etc. The "white" one appears to not have been connected to anything.

Good luck friend. I just lost my dad last month too. Know what you are going through. Hang in there bro.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #7
Thanks Oldeerslayer and Jimmykicker. Indeed the bracket on the right serves the back of the alternator. Still working on the other. The 2 bottom plugs (in my hand) actually go to the transmission. I will continue the journey -- appreciate your thoughts. Also, thank you for the kind words about the loss of my dad. He was a hero in my eyes -- those people never really leave you. I will keep you posted
 

·
Awww..you ain't got shit!
Joined
·
3,506 Posts
Thanks Oldeerslayer and Jimmykicker. Indeed the bracket on the right serves the back of the alternator. Still working on the other. The 2 bottom plugs (in my hand) actually go to the transmission. I will continue the journey -- appreciate your thoughts. Also, thank you for the kind words about the loss of my dad. He was a hero in my eyes -- those people never really leave you. I will keep you posted
Good deal. I've had my truck a long time and put the engine in in 2010. It so infrequently gives me trouble that I forget some of that stuff. I am always happy to help if I can. I don't know much, but I know a good bit about 1st gen s10s with 60 degree v6!!

Yep...losing a parent freaking blows. My dad was indestructible but I watched him turn to skin and bones in 15 months time. I'm still just barely processing it to be honest. I sincerely hope you don't have some of the d!ckwads like I do in my family making your suffering infinitely worse.
 
1 - 8 of 8 Posts
Top