S-10 Forum banner

1 - 9 of 9 Posts

·
.
Joined
·
3,904 Posts
Discussion Starter #1
i ordered the flex a lite 60 from summit racing and on the box it says for s-10 1982-1997. I got a 2000. will it still work? i don't want to open the box if it wont
 

·
.
Joined
·
3,904 Posts
Discussion Starter #2

·
Registered
Joined
·
4 Posts
Yeah it will fit in your truck. I had one in mine for about 2 years and it worked fine. You will have to leave off the bottom part of the fan shroud in order for it to fit right. And I also suggest wiring up the manual switch as well when you are doing the install, because "you never know." :cool:
 

·
Registered
Joined
·
214 Posts
i ordered the flex a lite 60 from summit racing and on the box it says for s-10 1982-1997. I got a 2000. will it still work? i don't want to open the box if it wont
It will fit. I have one on my 2000. I have it inside the stock cover so you can't tell its there. I just trimmed the lower cover to make room for the bracket and cut a hole in the side so I can get to the temp adjustor. Works fine. It' been on for almost 3 years now.
 

·
.
Joined
·
3,904 Posts
Discussion Starter #5
cool thanks guys. i'll be puttin it on tomorrow.
 

·
Registered
Joined
·
8 Posts
smokinchevy2000 & colabear I too have a flex-60 in my 2000 2.2/ 5spd just installed about 10 days ago only problem i've encountered is with the A/C running in stop/go 0-20 mph driving the fan doesnt seem to be able to keep up turn off the ac, temp gos right back to norm have you guys had similar problems?
 

·
Registered
Joined
·
4 Posts
smokinchevy2000 & colabear I too have a flex-60 in my 2000 2.2/ 5spd just installed about 10 days ago only problem i've encountered is with the A/C running in stop/go 0-20 mph driving the fan doesnt seem to be able to keep up turn off the ac, temp gos right back to norm have you guys had similar problems?

Yeah I had the same problem. I think the fan just can't move enough air to keep the engine cool enough when the A/C is on. I solved that problem though, I put the stock fan back in and BAM!:) overheating problem solved.
 

·
Registered
Joined
·
214 Posts
smokinchevy2000 & colabear I too have a flex-60 in my 2000 2.2/ 5spd just installed about 10 days ago only problem i've encountered is with the A/C running in stop/go 0-20 mph driving the fan doesnt seem to be able to keep up turn off the ac, temp gos right back to norm have you guys had similar problems?
I didn't have that problem. I did change out my coolant and went to Hy-Per Lube Supper Coolant. I mixed it with distilled water and it knocked 20 deg. of my run temp. You can get this stuff at Checker Auto and other parts stores. If you live in a cold area, you can mix it with anti-freeze and it will still lower your run temp, just no as much as with distilled water.

www.hyperlube.com
 
1 - 9 of 9 Posts
Top