S-10 Forum banner
1 - 20 of 37 Posts

·
Registered
Joined
·
295 Posts
Discussion Starter · #1 ·
Just picked up this 2000 ZR2 Blazer. 136k miles, with a rod knock (I have an engine from my 99 s10 zr2 that I did the v8 swap on all ready to go in), brand new BFG MT's, I'm excited. I got it for $1000. Only had to drive two hours to get it.







 

·
Registered
Joined
·
113 Posts
good score!
 

·
Registered
Joined
·
607 Posts
Looks like ya got a steal!
 

·
goin broke but n style
Joined
·
12,942 Posts
WHAT a STEAL. Looks good.
 

·
Registered
Joined
·
295 Posts
Discussion Starter · #11 ·
Are the wheels really that bad?
 

·
The Chop Shop
Joined
·
419 Posts
Nice truck, the wheels look just fine.
 

·
Registered
Joined
·
658 Posts
I honestly think those are the best set of rims the Blazer/Jimmy/Bravada had. I'd trade those rims for mine in a heartbeat.
 

·
Registered
Joined
·
295 Posts
Discussion Starter · #17 ·
I got underneath and found one of the main bolts that holds the front diff. MISSING. It's the one that goes through the busing on the driver's side. Who knows what that was doing... or how it happened. Also, I found a nut missing on the rear sway bar (it was pinned with the bolt, nut no nut on the back). Fixed that too.

I have a terrible vibration when I reach 30 and it gets progressively worse as I go faster. When I shift into neutral and idle drops, the vibration is still there. I don't think it's unbalanced wheels/tires... He said they were serviced a month ago when he bought the fronts. Also, the 4x4 buttons on the dash are not working well. I can't get it to go in 4hi, but it will click into 4lo (I hear a shift in the t case) but the 4lo remains blinking.

Is there some common thing that goes out on the tcase that would cause problems?
 

·
It really is a POS!
Joined
·
704 Posts
I honestly think those are the best set of rims the Blazer/Jimmy/Bravada had. I'd trade those rims for mine in a heartbeat.
Come trade me, they aren't pretty but hey...if you want em that BAD come take mine.
 

·
Registered
Joined
·
295 Posts
Discussion Starter · #20 ·
I found the terrible vibration. The front driveshaft universal joint was not seated between the aligning tabs on the front diff output. It was about 1/4" off-center. The u joint was bet to hell. I don't know who had their hands on this truck last... Unheard they did take it to a college to have work done. Boneheads.

Question, in 2HI should I be able to turn the driveshaft with engine running? Or is it engaged at the tcase all the time?
 
1 - 20 of 37 Posts
Top