S-10 Forum banner

1 - 11 of 11 Posts

·
Not an O.G.
Joined
·
670 Posts
Discussion Starter #1
Hey guys can you guys help me out on this? Sat. night I was racing my friends T100 and off the line I blew smoke a couple times when I punched it. :eyes: Is this a big problem? I think it's probably just because I'm running rich, but not sure. I was running 91 octane and I have a removed restrictor plate. Let me know what you think?


p.s. - I still killed the T100! :headbang:
 

·
BLAZIN SADDLE
Joined
·
1,394 Posts
Try cleaning the K&N to help get more AIR in. This may help the rich problem and if it still smokes when you punch it. it maybe BAD valve guides :jawdrop:



____________________________________________
02 WHITE BLAZER X
1-Leather seats and top door panels
2-GPS alarm
3-Billet Bowtie
4-255/45/18 Pirelli Zero's on HALO rims
5-Boston Acoustics speakers in doors/dash
6-Pioneer 6x9's in the back seat area
7-K&N GEN II
8-FlowMaster 40series with 2 1/4 pipe Magnaflow SS tip
9-2/3 DROP with Belltech Spindles and Blocks
10-Poweraid Spacer
11-Removed MAF Screen
12-JL amp and one 10” JL subwoofer
13-SS mirrors WHITE matching handles

And a list one mile long
 

·
WRX Style
Joined
·
368 Posts
If it shoots off smoke when you start it then it's your valve gaskets... they're just getting worse if it blows off smoke when you run it up... if it is, replace them and you should be fine
 

·
Not an O.G.
Joined
·
670 Posts
Discussion Starter #5
Valve gaskets? Really. Okay, I just thought I was running rich. And photo it's a brand new K&N.
 

·
Self Portrait
Joined
·
1,632 Posts
What color is the smoke.....blue...dark grey.....white? Does the smoke hang in the air or dissipate like steam? On a launch ... I think that I would go with a bad oil ring! Valve guides would give you a puff of smoke when you start the engine.....due to oil in the lifter gallery leaking by the stem after the engine has been turned off and pools in the cylinder... I could be wrong....what do I know?
 

·
Not an O.G.
Joined
·
670 Posts
Discussion Starter #7
The smoke dissipates like steam, real quick. I can barely see it through my rear view mirror. Hard to tell what color I think dark grey, it's real inconsistent when it's going to smoke. I didn't even have any today, but tom. who knows? It doesn't puff when I start it though.
 

·
WRX Style
Joined
·
368 Posts
SS4Real said:
Valve gaskets? Really. Okay, I just thought I was running rich. And photo it's a brand new K&N.
That's just mine, like I said I don't know anything about the newer trucks.. :D
 

·
Self Portrait
Joined
·
1,632 Posts
That is strange. Keep an eye on your oil level .... see if it changes any. It could have been moisture in your exhaust system, did you notice any water coming out of the tail pipe? If so it's no big deal. I wouldn't worry about it until it becomes consistent, then you can diagnose and deal with the problem.....if there is one.

Good Luck!
 

·
Deadbeat
Joined
·
1,331 Posts
mine does it too...do you run it hard alot? if not it could be carbon....the 4.3 isnt a very fuel efficient vehicle....alot of unburned gas when fulled will get by and you can only really see it in someone elses headlights....i would keep an eye on the oil and listen to the engine for weirdness....
 
1 - 11 of 11 Posts
Top