S-10 Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
152 Posts
Discussion Starter · #1 ·
i noticed today that the battery light didnt go off after the first few second like it usually does after i started my truck today. i dont know what the heck is wrong with it. there are no trouble codes and acording to the battery gauge theres still a charge i dont know what it is. if any one can help id apericiate it. i hope my alternator isnt bad but i dont think it is becase the gauge stayed normal.
 

·
Broken Handed Superman
Joined
·
6,283 Posts
have u started the truck again? and did it have trouble starting, i've noticed when i've had a low battery and the truck barely starts, my batt light stays on till its recharged.. if u go and start it now, and the ligth stays on, take a meter to it and see if the battery is reading around 14.4... if it isnt ur alt is more than likely shot...
 

·
Registered
Joined
·
152 Posts
Discussion Starter · #3 ·
its also a fairly old battery could it be that the battery is almost dead?
 

·
Registered
Joined
·
152 Posts
Discussion Starter · #5 ·
well i found out what it was my alternator was shot and it was driving on the battery but i got a new one and everythings good now i also disabled my daytime running lights. and bought some high milage oil, high milage oil filter, and some restore.
 

·
Professional Insultant
Joined
·
5,928 Posts
I had a wierd ooccurance with my pick up when I first got it (very next morning afer I bought it) I didn't know what the hell I was doing with the clutch, I've never drove clutch before and stalled it three times in a row, and when I restarted it had had a lot of trouble, and it rumbled really bad, and it was 'half' started? I romped the pedal to see if it was started, and it didn't respond at all, and I revved it again and it hesiteated then the engine rvved up, and was running just fine, and my battery light stayed on for the whle time of a 10 minutes drive, but I turned it off and restarted it and enver had that problem again, and it's a brand new battery.
 

·
Registered
Joined
·
152 Posts
Discussion Starter · #8 ·
i really knew the alt was dead becase driving home after buying a new one the odometer was so dim i couldnt see it and everything else was getting dim also. the only reason i thought it was the battery at fisrt is becase its a pretty gross old batery but it works great now after i start my truck it stays up above 14 unless my headlights are on then it drops to alittle below 14.
 
1 - 8 of 8 Posts
Top