S-10 Forum banner

1 - 8 of 8 Posts

·
Post Whore?
Joined
·
2,864 Posts
Discussion Starter #1
well my tranny in my 89 blazer 4.3 4x4 has been slipping lately, and finnally this afternoon it decided there wasnt anymore 3rd gear. i think im just gonna try my luck with a junkyard tranny that i can get for like $200 and i know someone that will put it in for $150...sucks that ive gotta change it, but i guess there is no way around it.
 

·
Post Whore?
Joined
·
2,864 Posts
Discussion Starter #3
well it goes into 1st and 2nd gear fine, but when it tries to go into 3rd, it just whines out like there is nothing for it to catch on to.sometimes in the morning it doesnt like to go into reverse either, like it wont fully engage...what do you think? a shop wants 1400 to do the tranny, how much would they charge to do the clutch plate?
 

·
Lunatic
Joined
·
257 Posts
we're talking about an automatic right? if so then there's no clutch plate, instead there are several clutch packs. if you're losing gears then your only option is a rebuild (or a junkyard tranny and hope it holds up longer than the warranty).

$1400 isn't to bad if it includes removing your old one and installing the new one. doing trannies on a 4.3 or V8 s-10 isn't terribly hard but it isn't fun either. there are two bolts that you have to get with long extensions and two that you have to get with wrenches (there isn't room for much else, one can be removed with a small ratchet instead).
 

·
Registered
Joined
·
2,144 Posts
Have you checked the tranny fluid level? I mean sometimes it's the simple things that make the difference. ;)
 

·
Registered
Joined
·
2,144 Posts
I just thought, maybe a plugged filter? Seen it before.
 
1 - 8 of 8 Posts
Top