S-10 Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
I have a 01 s10 2.2L with 50,000k, on the way home from a trip today my motor started shaking pretty bad while idleing. It goes away after 10 mph. When I got home I stuck my hand on the exhaust pipe and it sucked my hand then blew it back out then sucked/blow. My sevice engine light soon is on. does anyone have any idea what could cause this? Timing chain or maybe bad gas, bad motor mount?

please help
 

·
Registered
Joined
·
408 Posts
Sounds like a problem with the valves or timing chain to me. What I would do is see what the code is from the light being on and then maybe take off the valve cover and look in there to see if anything isnt normal. You can start the truck with the valve cover off...... just dont rev it up or oil will go all over. Oh and also if you do this be sure to plug the any lines that go to the intake you may have taken off so it doesnt idle high.
 

·
Registered
Joined
·
312 Posts
I don't think the new trucks have chains. I think they have gear drive.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #4
A mechanic is telling me that my first cylindar is only pumping 60 pounds of compresion. Does anyone know what it should regualarly be? He said my computer is not able to be linked up to, and is talking about a motor swap!

any advice on what I should do?
 

·
Registered
Joined
·
709 Posts
Make sure cylinder 1 is getting spark then mine was doing the same but i had a shorted coild which then fouled the plug and wires.... caused a misfire..... 2.2 with dead cylinder is no fun


JAY
 

·
Registered
Joined
·
68 Posts
motor swap for a simple valve job? thats ridiculous. Your mechanic is a pos. Valve job shouldnt be that much money and is no reason to switch motors
 

·
Registered
Joined
·
19 Posts
Discussion Starter #8
Mechanic is telling me that my 1 cylandar is washed out. He says a rebuild is more expensive than a swap.

He says my cpu started to malfunction causing more gas to flow into 1 cyilander.
 

·
Registered
Joined
·
408 Posts
Sx192 said:
oh and regular compression should be around 190-210 pounds

Wow that seems high but, mine has 185 across all 4 and the manual says 140 is the normal. I have a 1995. Is the book wrong?
 
1 - 9 of 9 Posts
Top