S-10 Forum banner
1 - 20 of 26 Posts

·
Dey took rrr jobs!!
Joined
·
4,322 Posts
Discussion Starter · #1 ·
When I air out my bags and at the very end the dumps make this god awful growl sound. I dunno how to explain it I wish I could record cuz it sounds terrible, its like the valves are friggin farting or something lmao. Anyways I'm curious what the hell is making it to that! I've had it ever since I bagged the truck but I guess it never really botherd me til now.
 

·
NTBSSHEVN
Joined
·
9,248 Posts
Wow I have never heard a problem like you got. Do u have the air mufflers or any type of reducer in the dump valve. I don't even know but I bet it sounds really funny since its got a farting sound to it.
 

·
Dey took rrr jobs!!
Joined
·
4,322 Posts
Discussion Starter · #3 ·
Well actually I do have mufflers on the dumps. Err I guess that could be the problem but I dont wanna take em off cuz you gotta have some backpressure ya know.
 

·
Registered
Joined
·
13,578 Posts
GriMSysTeM said:
Well actually I do have mufflers on the dumps. Err I guess that could be the problem but I dont wanna take em off cuz you gotta have some backpressure ya know.
You don't get the psst psst with the mufflers on do you? Try takin em off tho, mine don't have any backpressure and they work fine.
 

·
NTBSSHEVN
Joined
·
9,248 Posts
I had the mufflers on mine and they sucked. Wasn't making psst psst sound I was after so I took em out and have been like that for 5 months now and no problems.
 

·
Dey took rrr jobs!!
Joined
·
4,322 Posts
Discussion Starter · #16 · (Edited)
Yay more responses...Anyways yea they still make the pssh pssh but its the last second it makes the growl sound. From dave's reply it looks like its not the muffler. I'll try cleaning em up and hope that works but what should I check for electrical exactly?
 

·
Registered
Joined
·
13,578 Posts
GriMSysTeM said:
heh I didnt actually go out and buy em..when I was buying all my bag parts from larry they were in there with the rest of the fitting so I used em.
Yah, he sent me those also. I installed them, but it dumped way slower and didn't make the classic pssst, so I took em off. Check your electrical connections sure, but I don't see the valves being dirty, considering it's happened since the valves were new and that just the dump valves are doing this.
 
1 - 20 of 26 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top