S-10 Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
2,740 Posts
It's a 4 door SUV based on the fact it has the auto climate HVAC.

Does your HVAC fan work?

It's been awhile since I messed with an auto climate truck, but I want to say it has to do with the blower motor or the black module in the bottom right of your picture.

If that's not it, take a clear picture of the blower motor area, but with more of the engine compartment showing.
 

·
Been there Done it
Joined
·
15,261 Posts
Might be the connector to the front differential electric/vacuum switch if you have Autotrac. (4 button switch) 3 button non Autotrac is on the TC. The Autotrac has an electric solenoid to turn on the vacuum for the front diff. on the firewall.
Font Rectangle Parallel Slope Number
 

·
Registered
99 Blazer
Joined
·
378 Posts
Might be the connector to the front differential electric/vacuum switch if you have Autotrac. (4 button switch) 3 button non Autotrac is on the TC. The Autotrac has an electric solenoid to turn on the vacuum for the front diff. on the firewall.
View attachment 367436
This is the auto trac vacuum switch. It sits way to far, in the center of the firewall by the wiper motor. I've looked on all my blazers with all options from different HVAC systems, transfer cases, federal and California emissions, etc. Non of them have that connector. I have no idea...
Automotive tire Pipeline transport Wood Gas Plumbing
 

·
Been there Done it
Joined
·
15,261 Posts
Or a previous owner had a security system or something similar installed and has since removed it, but didn't bother to remove the wiring? The electrical tape at that point is done relatively neatly, but doesn't look factory. Seems a bit tight.
 

·
Registered
Joined
·
459 Posts
Everything seems to be running normal. No lights or codes being thrown. But there is this harness not attached to anything by the blower fan. Any ideas what it’s for, or needs to be connected to? It’s a 2001 4.3, auto transmission with 4wd
One wire means 'sensor' usually . Object will be with in reasonable reach of cable and there won't be a choice. This only applies to OE and unhacked vehicle.
 

·
always something new
Joined
·
54,951 Posts
The one in the first pic?
To what?
i have no idea , i looked on my truck ( 01 ) but nothing in that area . i have original wires taped just like the one in the pic
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #15 ·
I am the original owner, so I know no one hacked into my wiring.
But everything is working fine, I just was puzzled by by his harness when I replaced the blower motor and saw it tucked back there
 
1 - 18 of 18 Posts
Top