S-10 Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
75 Posts
Discussion Starter #1
Recently my brake light has started flashing. It flashes in a pattern of 3 short flashes then 1 long flash. Does this translate to some kind of code that can be looked up?
 

·
frequent flyer
Joined
·
43 Posts
i know that's a diagnostic code for the rear abs but I don't know what component its for.I can find out tomorrow at work unless someone else knows.HTH
 

·
Registered
Joined
·
265 Posts
i looked in my chilton's manual and now i am lost as hell:confused: ...ive only delt with the self-diagnostics and the check engine light then gone from there...but i have an 85 so no ABS...i hope someone can figure it out for ya...damn charts
 

·
Registered
Joined
·
75 Posts
Discussion Starter #6
just to clarify, it is my dash light. The brakes work fine and the reservoir is filled up so i figured it was abs related. If you could tell me which code taht would be great. Thanks for all your help guys!

ryan
 

·
Registered
Joined
·
152 Posts
You ned a jumper on first Gens

Haynes has a list that of the codes after you run a jumper from Term 'a' to Term 'h' of the ALDL (i.e. Top right (a) to bottom (1) from the left (h).

Under the 4WAL cides a 31 is "right rear speed sensor circuit" and says an intermittent signal is a sign of a loose connector.

If you have a 2nd gen or did not jumper your ALDL, I really don't know what code it's sending.
:soap:
 

·
frequent flyer
Joined
·
43 Posts
according to my manual you need to jumper A and H at the ALDL to retrieve the codes.A is the top left corner of the connector and H is 2nd from the left on the bottom.start counting with the long flash which would make yours a code 13 faulty ECU = big money.I would take it to a shop and make sure before I spent the money on a new computer.HTH let me know what you find out.
 

·
Registered
Joined
·
75 Posts
Discussion Starter #9
perhjaps I should have clarified earlier...

This is the weird part.

The brake light is falshing and I am not jumping the harness at all. You start the truck up and drive it down the road and this code flashes out the brake light. Is that normal? Or is there a permanent jumper in my circuit or something?

ryan
 
1 - 11 of 11 Posts
Top