S-10 Forum banner
1 - 20 of 26 Posts

·
Registered
Joined
·
1,261 Posts
Discussion Starter · #1 ·
Well, I did it, I broke my Air Zenith. I have come to the conclusion that anything and everything on my truck will break no matter what, even if i buy the best parts. I have had my Air Zenith for only 3 months and now it wont pump up my 5-gallon tank over 60psi. Here is what happened. I was hitting switches at a local car show and then i parked the truck and let it sit running so the tank would fill back up. After a while i noticed it had been running for quite a while longer than usual. I looked at my gauge in the truck and the tank was only at 175psi and not moving going up at all, even though the comp was runnning. I have it on a 195psi pressure switch and a 5-gallon tank, an AZ should be able to handle that right? Well, i let if cool for a few hours, emptied my tank and tried to see if it would fill the tank, now it wont go over 60psi! I even took off the leader hose and tried hooking the comp up directly to the tank to make sure my check valve didnt have a problem. Stil only 60psi. So now i gotta send it back. Any idea why it would have died? It is mounted in my bed, under my tonneau cover to keep it out of the weather, could it have got to hot under there? It was warm under the tonneau when i opened it, but i wouldnt think hot enough to kill the comp. Although the comp itself was very very very hot since it never reached 195psi and the pressure switch never cut it off.. derrrr.. anyone else break their AZ yert?
- Mike
 

·
~~~~
Joined
·
23,957 Posts
Piston ring seal
They will send you a new one call britt ASAP!
 

·
~~~~
Joined
·
23,957 Posts

·
Registered
Joined
·
1,261 Posts
Discussion Starter · #4 ·
DJDAudio said:
Piston ring seal
They will send you a new one call britt ASAP!
I just call the number on the AZ site and ask for britt?
why do ya think it died? Think it got to hot being under my tonneau cover?
- Mike
 

·
Registered
Joined
·
1,261 Posts
Discussion Starter · #5 ·
Hey Doug, what do you think about running (2) 5-Gallon tanks with (1) AZ and (1) Viair 480c comp and a 200psi pressure switch (actually cuts off around 190, cuts on at 165) and having the comps in the bed under the tonneau cover? Will the compressors be happy with that setup for a somewhat switch happy person or will that be too much for the compressors to handle? I figure that one AZ should run a 5-gallon fine and a 480c should run a 5 gallon fine, so both of them running a combined 10gallons should be fine right? Its a daily driver so i want it to be reliable! Oh yeah... and when are we gunne be able to buy the boost system!!? :)
- Mike
 

·
Registered
Joined
·
249 Posts
the only problem I have had with mine is the air cleaner popping off and the color fading....Needless to say Britt was on top of it. They will stand behind their product. I run 2 3 gallon tanks to 175 daily
 

·
mini' less.... :(
Joined
·
436 Posts
mine wont build any pressure at all, i can take the leader hose off the tank and put my finger over the outlet and it just pushes the air back outta the inlet, i have already emailed britt and im hoping we can get it takin care of. i havent used this thing but 3 months maybe. its kinda got me irritated, gotta worry about my nitrogen bottle running out on me while messing around. i should just put my sanden on the truck and call it good:D then the AZ on top of that :D:D
 

·
Registered
Joined
·
12,215 Posts
xtrmlow said:
god i hope we dont start finding problems with this shit

Actually we have.. lol this is the problem.. It's no biggie tho.. I mean atleast they support their compressors unlike viair.. Viair is gay about their waranties.. That's if you can even understand what them asians are even saying anyways!
 

·
Registered User
Joined
·
1,721 Posts
i have a friend who had both of his AZ's crap out last weekend. one was bought in November, one in December. AZ shipped him out 2 rebuild kits overnight free of charge.
 

·
~~~~
Joined
·
23,957 Posts
david4991 said:
i have a friend who had both of his AZ's crap out last weekend. one was bought in November, one in December. AZ shipped him out 2 rebuild kits overnight free of charge.

That is great to hear :tup:
 

·
Registered
Joined
·
1,261 Posts
Discussion Starter · #13 ·
david4991 said:
i have a friend who had both of his AZ's crap out last weekend. one was bought in November, one in December. AZ shipped him out 2 rebuild kits overnight free of charge.
Ahh... hmm, i hope they fix his design flaw! I dont want to have to get this booger re-done every few months! I just went ahead and shipped them out my compressor since i have a backup one to use, that way they can inspect it and learn from the defects of it.... plus once they get it they fix it that day or the next day and ship it right back out, no biggie
- Mike
 

·
~~~~
Joined
·
23,957 Posts
thepunkerguy said:
Ahh... hmm, i hope they fix his design flaw! I dont want to have to get this booger re-done every few months! I just went ahead and shipped them out my compressor since i have a backup one to use, that way they can inspect it and learn from the defects of it.... plus once they get it they fix it that day or the next day and ship it right back out, no biggie
- Mike

Yup they already have a fix for it ;)
 

·
~~~~
Joined
·
23,957 Posts
thepunkerguy said:
Awesome, so i guess that means they will be applying that fix to mine too hu?
:)
- Mike

Yup you will not have to worry now :cool:
 

·
mini' less.... :(
Joined
·
436 Posts
i wish they would just send me a rebuild kit, but they are making me send mine back to em. who knows how long they have the thing. when the thing worked it worked great, but lately it started to take along time, now it wont do shit. kinda sucks
 
1 - 20 of 26 Posts
Top