S-10 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1,828 Posts
Discussion Starter #1
Guess this is the right forum. I'm replacing my Carrier bearing for the 3rd time since I dropped my truck less then a year ago. went to a 2/3 and replaced it 2 time's, and now pulled a leaf with 4" block and 1/2" shim and it's bad again. going to try a 1" shim, is that the problem or could it be something else?

The bearing is pushing out the back of the rubber, and it's pulling the driveshaft out of the tranny about 1/2-3/4".
It's on a 90 S15 ext cab 4.3 auto
 

·
Registered
Joined
·
87 Posts
Have you had any drive shaft mods done? it would benifit you to have it shortened.
 

·
Registered
Joined
·
10,898 Posts
Well it seems strange that an x-cab is doing this. I have like
a 3/4 on my ole Slonoma and had no probs. I did take a
measure of the driveshaft before and after. The slip joint that's
built into the second drive shaft is there to allow for the in and
out movement of the driveshaft and the truck goes up and down
as the suspension is working. The driveshaft has to have 1/2 to
3/4 play in it so as not to destroy the pinion bearings in the
rear end or the rear of the trans. If it didn't have any play the
driveshaft would JAM itself into either the trans or rear end.

You might ck the free play at the slip joint where the second
u-joint is. The carrier bearing is being jammed out to the rear
if I read you write which could mean there's no free play left
when to compress the leaf springs. That's why having that
3/4" free play is so critical. Here'a link to one of the best
D/S places here in So Cal..Ck out their tips, Q&A towards the
bottom >

www.iedls.com
 

·
Registered
Joined
·
1,828 Posts
Discussion Starter #4 (Edited)
It has the free play in the joint's it's just pulling the bearing out of the rubber tward's the rear end. Don't understand why. Went to put another 1/2" spacer on the one that's their now and their isn't enough room for the middle U joint's to move up without hittin the cab floor (tried beatin the floor with a mini sludge but it didn't do much).

Anyone with ext cab 1st gen runnin a 1" carrier bearing spacer? What did you have to do?
 
1 - 4 of 4 Posts
Top