S-10 Forum banner

1 - 20 of 44 Posts

·
LSxtremin FoLyfe
2000 s10 SCSB
Joined
·
1,434 Posts
i got some on mine that i got off ebay,i dont have a pic but i will take one today and let you see,i love the way the look on the truck
 

·
Registered
Joined
·
3,577 Posts
here are a few i got em about a month ago.. the fit isnt great but they do look good.





 

·
s-series #2?
2004 Blazer ZR2 w/ nv3500, 5.3 LM4 swap
Joined
·
24,783 Posts
yea. cheap aftermarkets from ebay dont fit right ive heard... but i think its more luck of the draw
 

·
LSxtremin FoLyfe
2000 s10 SCSB
Joined
·
1,434 Posts
all i did was smack the holes where the 2 long bottom clips slide into the rad support,just made them tighter and than they dont bounce or slide around,and if you have an aftermarket hood the gap looks off do to the fitment of the hood
 

·
Yea did
Joined
·
129 Posts

·
Starting from scratch...
Joined
·
3,349 Posts
here are a few i got em about a month ago.. the fit isnt great but they do look good.
Not to go off topic, but that's gotta be a Goodmark hood, right? My passenger side front corner doesn't match the fender line, either. Badass paint job, b.t.w.

I have a '97, no composites, so I can't do halos. It's a shame. I love the way they look on the '98s and up.


There, I brought it back on topic....:p :D
 

·
Registered
Joined
·
3,577 Posts
yea man its a goodmark.... still gotta do some readjusting .. but its not to bad. wishing i woulda went with the tapperd cowl now tho
 

·
head turner
Joined
·
211 Posts
Discussion Starter #18
just got my halos in today. putting them in tomarrow because i dont have the best of luck with wiring. getting them hooked up to a switch and to my remote start. pertty happy. hopefully mine line up right and dont look like p.o.s. ebay ones haha even though they are from ebay :p
 

·
Registered
Joined
·
20 Posts
not the best pics but..
day


and night
 

·
head turner
Joined
·
211 Posts
Discussion Starter #20
so i just got my angel eyes in. we hooked them up to my all time drive light or what ever you would like to call them. and there is 2 probs. 1)left halo flickers and 2) when the light sensor goes off. now all my front lights turn off have no idea wtf is going on so im giong to re-wire them to a switch in the cab. they also have the infamous fogging prob. does anyone know how to fix this because there supposed to be DOT approved. . . heres how the headlights look now.
 
1 - 20 of 44 Posts
Top