S-10 Forum banner
1 - 8 of 8 Posts

·
has no indigoblue2kdime.
Joined
·
904 Posts
Discussion Starter · #1 ·
i've been hearing a 'whirr' from my speakers/somewhere in the interior of the truck for damn near a year now, it increases as my RPMs increase and remains constant when im at a constant rev. also now when i take my truck out of gear and coast it idles at about 1500rpms for a little while then settles down and idles at a grand. another thing that happens is when i am in netural slowing down kindof hard (like from 55 to a stop) my lights will dim and then come back up a few times. this isnt a consistant thing it happens kindof randomly.

ok thanks for reading and if anyone has any ideas about this being the alt. or not they would be greatly appriciated...
 

·
Usted huele como un asno
Joined
·
1,197 Posts
that sounds like alternaor whine. i had that in a previous car that had an aftermarket sound system. i fixed the problem by running the audio cables down the passenger side, then the power cables down the drivers side. you'll know if your alternator is going out by looking at your battery guage, if it reads no volts, or slowly drains down, it's probobly bad, you can also check it by starting your truck and removing the negitive side of the battery. if it dies out, alternator is bad. if it keeps running, it's fine. you could always remove it and take it to autozone and have them check it.
well that's my .02 pm me if you have any more q's. i deal with that problem a lot. also it doesn't hurt to hit all your alt connections with a wire brush and make sure all your wires are in good condition. it sucks when you replace a 200 dollar alt to find out you just had a bad battery wire that costs like 20$
matt
:monkeypee:booty:
 

·
has no indigoblue2kdime.
Joined
·
904 Posts
Discussion Starter · #4 ·
so alternator whine is just an effect of the sound system, not the alternator going bad... ?
 

·
has no indigoblue2kdime.
Joined
·
904 Posts
Discussion Starter · #6 ·
BeyondeXtReMe said:
depending what year of vehicle it is,(if it's a newer one) it isnt a good idea to disconect the negative battery.
its a 2000....
anymore suggestions?
 

·
Usted huele como un asno
Joined
·
1,197 Posts
well , i have a 2000 ext cab. 1st of all, do you have aftermarket stereo equipment installed? if not then, i have no clue, but i would have to expect if you've been living with it for a while, though annoying, it's probobly not a pressing issue, just a bad ground or a not so great connection somewhere. as for the removing of the negitive side of the battery, BeyondeXtReMe, why do you say it's not a good idea, i've done it to my truck when my alt went out, it stalled and i bought a new on and everything was fine. i'm not callin you out, just would like some more info for future referance
 
1 - 8 of 8 Posts
Top