S-10 Forum banner

1 - 12 of 12 Posts

·
3 Leaf Fab
Joined
·
4,082 Posts
Discussion Starter #1
so, after wheelin the piss out of my s10, the front alignment is all out of whack. is this a common problem? looking from the front, my tires now do this number, \ /. i cant see any bent a-arms, and it has new ball joints, and wheel bearings feel good. but somehow i have totally destroyed my alignment.
 

·
s-series #2?
2004 Blazer ZR2 w/ nv3500, 5.3 LM4 swap
Joined
·
24,783 Posts
well depending on how hard you have been working it its possible.
if a chick can hit a curb and need an alignment, you can hit boulders and need an alignment lol
 

·
3 Leaf Fab
Joined
·
4,082 Posts
Discussion Starter #5
That's your camber. Just give your T-bars a crank until the wheels are corrected. Confirm with a level.
nah, i refuse to touch the t-bars. besides, now that i have had my fun with this "stock" s10, i can tear it down an build it the way i want it (meaning that front end has seen its last days anyways).

forgot to mention, i was just asking for curiosity, not so i can fix it.
 

·
3 Leaf Fab
Joined
·
4,082 Posts
Discussion Starter #7
OK. But it looks to be your torsion bars that need adjusting. That is why they are adjustable...
if they were sagging, wouldnt the tires be more like / \? that is assuming the a-arms do not form a parallelogram as i first thought they would. if they were as i first thought, the tire should always stay level as the suspension cycles. but that would not explain why they are \ /, so i must be wrong. i even suspected that i may have bent a t-bar, but i doubt it and i cannot see that changing my alignment this way. also, the crossmember that holds the crank bolts is all bent and distorted now.
 

·
3 Leaf Fab
Joined
·
4,082 Posts
Discussion Starter #9
1 - 12 of 12 Posts
Top