S-10 Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1 (Edited)
91 s-10, 5 speed, 4x4 (this is my buddies truck, so i'm not the expert on the s-10, but i can tackle anything....)

The oil filter relocator that bolts to block is leaking like a sieve.....

A few questions:

1. how the hell do i get to this?
2. where the hell are the motor mount bolts (i didn't look superhard, but with all the 4WD stuff in the way, can i get to them? ( i may have to lift the engine this afternoon....)
3. how do i fix this...the Autoparts store has no gasket for this....
4. help!!!!

Thanks guys....
 

·
little pink pink
Joined
·
5,036 Posts
I had this happen on my 2wd 2.8l....you have to jack the engine up and take the motor mount completely off the engine...they do make a gasket for it...I got one when I rebuilt my engine the first time....the second time this started to leak on me I took it to a shop they charged me like $80 to fix it...I would have to say it was worth the money to take it somewhere... it was biotch to fix...

just my 2 cents..
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
you had a relocator on your 2WD? interesting.....my other buddy's S-10 with 2.8 2wd has his filter on the block.

I had a feeling that this is going to be a total Beotch. I can't even see the motor-mount to frame bolt.....
 

·
Registered
Joined
·
12,726 Posts
Ok. I just did this to my dad's 90 4.3 4x4 blazer WITHOUT moving the motor :D he had a bad hose so we switched the whole assembaly out.

1st off the gaskets will help bigtime! I got them at a local hardware/machine shop. The chain stores never carry them.

ok now on with removal I used a 12" or so extention on my rachet to go from infront of the front axel back to the side bolt that holds the hoses on to the sleve. once you crack that loose there will be a lot of oil commin out so have somethin ready to catch it. Then take the two bolts out of the sleve and the sleve should drop right off.

replace gaskets and install is just about the same as removal but i recomend before you put the sleve back up in place put the hoses on and get the bolt started it will help later. then put it up and tighten all of it up. It took me about an hour to do it the first time when i didnt have the gasket set yet. but then after figuring out to get the hoses on first cut the time in half.

any other questions just ask!
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
KUSTOM!!!`

I did it!! had to pirate a gasket from a oil filter, and a 'make-ur-own-gaskt' piece intended for a thermostat. pretty easy. Yeah, now i get the email notification that warns about the 1/2 gal of oil that is to spill out...LOL!! Now....how the hell do we do the starter? It's extremely stuck. lol!

We had to use about 24" of ext. it really wasn't too bad.


I think the starter is going to be a total BEATCH!!!!:drinkhaha :evilg: :bash:
 

·
T/A drivin foundin member
Joined
·
538 Posts
i have an 88 4x4 with the filter on the block. i think with abs came the remot emount locators
 
1 - 7 of 7 Posts
Top