S-10 Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
Ok... got my carb squared away and now on to other issues. A long time ago, I bought a used 5spd (to replace my 4spd) for my '84 2WD 2.8L because I was doing a lot of highway driving. The problem I faced then (and still now) is that the speedo hook-up on the 5spd tranny was for an electronic speedo, but mine is a mechanical hook-up (cable driven). Therefore, no speed or odo. Was never a problem in my old state due to lax laws about vehicle conditions. However, now I live in NY and must have the damn speedo working! Other than finding another tranny with the right hook-up, what are my options?

Are there any aftermarket speedo's that can hook right up to the tranny? I really don't care if it fits in the dash cluster, I could mount it elsewhere. Drop me a few ideas... the least expensive the better!
 

·
Registered
Joined
·
13 Posts
what are the diffarence in the year of truck the new 5spd came from?? i did a tranny swap in a pontiac where the tranny i put in had the mechanical and the pontiac was a digital. anyway all i did was pulled out the sending unit from the tranny and swiched them... look on the side of the tranny where the cable would attatch if it comes out then you should be able to interchange them..

hope this helps

jeff
 

·
Registered
Joined
·
22 Posts
Discussion Starter #4
Thanks Jeff! I hadn't thought of that! Since I'm going the other way, I'm not sure if it's possible, but I'll give that a shot! I'm not sure what year the 5 spd is from, but I bet it was around '87 when the dash changed once they started using the electronic throttle body. Not sure though... Anybody else know if switching the sending unit on the tranny might work?!
 

·
Registered
Joined
·
22 Posts
Discussion Starter #6
It was originally a 4spd stick. I lost 2nd then 3rd, so I had to get a new tranny and the salvage yard had this 5spd. They didn't know what year it was from, but did know it was a borg warner from an S10.
 

·
ROB
Joined
·
128 Posts
Funny, I had a 5spd, and it was cable dirven (84 s15)
I swapped it to a auto 700r4 from an 83 s10.
It was also cable...maybe my trucks are just not up with technology? Hahha
Anyway, the sending unit is probably the way to go.
Sounds about right.
Im pretty sure every transmission has a spot for the cable (I THINK) correct me if im wrong.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #8
cool! Thanks spdsk8r! Now I just have to find a mechanical sending unit! I'm having a tough time finding junkyards in my area that have 80's S10's!!! If anybody has a lead on where to find this sending unit, let me know! I've not been able to find a replacement from autozone or pepboys or napa. I bet I'm gonna have to find a salvage part.
 

·
Registered
Joined
·
13 Posts
if you still have your old tranny look on it to see if the cable unit comes out... im not really sure about the s10s i do know that when chevy built there front wheel drive trannmissions the sending units do come out. they are held in with one bolt.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #10
Unfortunately, I replaced the tranny about 8-9 years ago and got rid of the old one way back then. I believe the old sending unit is the same (one bolt drop-out) as the one I have now. I'm just not sure if the gears in the tranny will match-up. My bet is that they will, since GM kept costs down by making parts interchangeable. I highly doubt they would have spent the $ to re-engineer a tranny just for the speedo connection. Now all I have to do is find a mechanical *&%#-ing sending unit to test my theory!

Grrrrrrr
 
1 - 10 of 10 Posts
Top