S-10 Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
214 Posts
Discussion Starter #1
I just bought my '01 Xtreme 2.2L used with about 1000 miles. I've been watching the gauges the last few days and it seems like my truck is running exceptionally hot. It typically stays right in the middle at 210. I'm used to my cammed, high compression, iron block Camaro running right at 170, so 210 seems dangerously high to me for a low output 2.2L. Am I out the normal temperature range, or does everyone's 2.2 run this hot?

-Chris
 

·
low and slow
Joined
·
430 Posts
My 99 has run at about the same area since new. these little 2.2s run kinda hot for some reason.
 

·
Registered
Joined
·
214 Posts
Discussion Starter #5
Interesting. lowxtreme, ConneticutX and I all have Xtremes, and danthe man has a regular S10, and he runs at 180. I wonder if the front bumper cover or the grille on the X trucks impedes airflow to the radiator on some way. Any insight or comments?

-Chris
 

·
low and slow
Joined
·
430 Posts
I think my 95 2.2 ran right around the same as my x does.
 

·
Ahhhhhhhhh Satisfying!!!
Joined
·
5,174 Posts
I run right under the middle line which I think is 210???

Althogh I have that Master Image Customs Grille which blocks most air from going to the radiator (fast flames) and I did notice a slight increase in operating temp.....nothing too drastic though
 

·
Registered
Joined
·
49 Posts
210 or just under is normal for most 2.2's . Have you thought about a high performance electric fan to overcome the effect of the fast flames grille. This also frees up rotational drag on the motor meaning a small horsepower gain.
 

·
Ahhhhhhhhh Satisfying!!!
Joined
·
5,174 Posts
I've been thinking about it, how much $$$???? I won't be doing much until next month (INsurance and payment this month....arggghhh) I want a JET stage II chip as well, I was going to get them at the same time.......

It is right under the middle line......so its not too much off, but it did go up a little bit......

Caleb
 
1 - 11 of 11 Posts
Top