S-10 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
01 zr2 abs pulses on light braking, such as coming up to a stop sign. Not really sure what it is, as I have only had the truck for about a month. It's kinda dangerous though, as I have almost slid into people in drive thrus, slid out into oncoming traffic from a side street, ect... The ABS module pulses a lot during light braking, which I can feel in the pedal, and sounds almost like a metal grinding noise. Can't seem to find an answer for it, and I don't wanna go dropping a couple hundred dollars on a new ABS module if there's something else that can be done to fix it. Any help would be greatly appreciated.
 

·
Registered
Joined
·
6 Posts
Dirty or faulty wheels speed sensors. It's a pretty common problem....
ABS Activating Under Light Braking

In the mean time, you can pull the ABS fuse in the box under the hood to disable the ABS. Braking will be normal aside from the lack of ABS and the ABS light in the gauge cluster being lit.
Thanks for sharing this, mine does this in very light snow even (bad), i have been wondrering if and how to bypass when and if it snows here in va.in the future. Thanks again !!
 

·
Been there Done it
Joined
·
8,424 Posts
Cleaning the mounting surface on the sensor and hub usually cures it. A dab of grease to prevent future rust helps.
 
Joined
·
40,298 Posts
When I had the Bravada and it had the problem I just pulled the ABS fuse underhood. Not recommended for people that don't know how to modulate braking/have never driven anything without ABS. A proper fix is always the best way though.
 
1 - 6 of 6 Posts
Top