S-10 Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
LOL! I feel so dumb asking this... But I don't think mine lights up in the cluster. I have the battery light,the check gauges light, and the ABS light when I turn the key on. But I don't see a Service engine soon. I'm having some problems with it running right sometimes. But I'm really starting to worry about what all is being hidden from me in my blazer. I just bought it a month ago. Anyone have a pic of there cluster lit up before you start it, or with the SES light on?
 

·
98 s10 limo
Joined
·
122 Posts
'98 dash with out tach, automatic
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #3 ·
I'm going to go look around tonite in my cluster. I didn't know if the check gauges light acted as the SES light or not. I definately don't have the "service engine soon" light coming on when I turn the key on "ignition". Plus I just took my cat off and I should be throwing the SES light now also. Just to make sure it doesn't make a difference.... My blazer also has the tachometer. Is the light still up in the right hand corner? Thanks for the pic though. Not too many dummies ask where is the SES light... Mainly just what is it? LOL!
 

·
Extended cab or no cab.
Joined
·
19,984 Posts
I think on both of my trucks WITH tachs, it is right above the left turn signal light.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #5 ·
Yep. You're right cpolaris502... It's in the section of light in the upper left hand side. I got my bright LED flashlight out and looked around for it. It's not coming on with the key. So I guess tomorrow I'll find out if the guy I bought it from pulled the bulb out. I just bought it a month ago, and have had some weird issues with mpg's. It sounds bad that I was too ignorant to not find the SES light:eek: . But I'm actually not a complete noob at cars believe it or not. Well I'm off too get the computer scanned I guess. So I can really find out what all is wrong with it.:rotf: This explains why I picked it up for $1000 less than any other's for sale in my area....
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #6 ·
Well.. it wasn't as bad I fuigured it was going to be. O2 sensor on the drivers side is bad. But this is after I cleaned the EGR, and IAC valves ane reset the computer. I can't believe some people would rather pull the SES bulb than tell a buyer that it needs an O2 sensor. Like I said though... at least it's a minor problem.
 
1 - 6 of 6 Posts
Top