S-10 Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
I'm wondering if anyone has a picture of the 2200 engine which clearly shows all the components and sensors on the engine.

I was just at a j yard to pull an oil pressure sensor but couldn't identify which one it was. I'm looking to avoid paying money for a repair book...

Thanks
 

·
Premium Member
Joined
·
1,144 Posts
it's just few inches behind oil filter housing.has wire w/plug on it and you need a large deepwell socket to remove it.look at the junkyard turbo thread you'll see his block out of truck and a hardline oil feed coming out of it to feed turbo.
 

·
Registered
Joined
·
22 Posts
luckily I just changed my engine out so I took this pic of my old engine sitting in my garage right now. I circled the oil pressure sensor, but you might want to get a new one, you'll never know what shape its in when you get it used.
 

Attachments

·
Registered
Joined
·
15 Posts
Discussion Starter · #5 ·
luckily I just changed my engine out so I took this pic of my old engine sitting in my garage right now. I circled the oil pressure sensor, but you might want to get a new one, you'll never know what shape its in when you get it used.
Thank you for the picture. It helps a lot.

Would it be too much of a bother for you to mark what the other sensors are? I know one is the cam sensor.

I can get a used one for next to nothing, so might as well pull it first and if its bad, then I can buy a new one.
 

·
Registered
Joined
·
22 Posts
Alright I'll mark the other sensors. But then I am done for the night, too tired to stay awake anymore. My crank sensor wouldn't come out, it broke off when I tried taking it out, that is why you don't see the connector plug.
 

Attachments

1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top