S-10 Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
175 Posts
Discussion Starter · #1 · (Edited)
I have a 98 s10 2.2 4cyl. When i first got my truck it misfired or "spit". One day i hit a huge bump, the engine light went off and it ran just fine. Figured that the EGR valve was stuck and got knocked loose? Yesterday it started doing it again so i need help finding the valve so i can take it off and get it unstuck or replace it. Any help would be appreciated. I searched but couldn't find the right answer. Also is there a way i can test the injectors one by one. I believe one of the injectors is bad as well, but not sure which one. Thanx
 

·
Local Tech
Joined
·
5,407 Posts
98 is a funny year. My 98 had an egr valve, but i dont think all of them had one. Mine was in the rear, left-centerish. If it had teeth, it wouldve bit you already lol
 

·
Registered
Joined
·
175 Posts
Discussion Starter · #3 ·
Yeah i think i found it, took it off sprayed it with some wd-40 and messed with the valve. Truck is running smooth again, but eventually i'm going to have to replace it.
 

·
Local Tech
Joined
·
5,407 Posts
Yeah i think i found it, took it off sprayed it with some wd-40 and messed with the valve. Truck is running smooth again, but eventually i'm going to have to replace it.
that valve is not cheap.... make sure that thats it first
 

·
Registered
Joined
·
175 Posts
Discussion Starter · #5 ·
that valve is not cheap.... make sure that thats it first
Yeah it keeps going back and forth! One day it's smooth riding other days it's spitting/missing/rough idle? I'm not sure if that is the problem. Maybe i have a bad injector? If i took it to a shop would they be able to tell me the specific problem or run tests?
 

·
i saw what you did there!
Joined
·
3,573 Posts
remove the egr and clean carbon out of it make sure its closed/seated all the way. reinstall it with new gasket and dont plug it in, run it for a couple days without it connected to wiring and see if is better noticeably

if no good then try another map sensor and check fuel pressure at rail

also try another crank sensor or cam sensor from a known good runnign engine, this is why i keep parts like this around from engine swaps so i can try them on engines that are messing up

crank sensor can start failing when hot

so can an ICM

theres alot of possibilities here and it can be real fun to figure what part is dying.

some parts dont work right when cold and others dont work right when hot

you just have to know from experience which ones will do it when

so its fun..

usually a stuck egr will cause either hard to start or stall when fired up

bad map sensor either bad idling, or stalling out when coming to a stop in gear after having been cruising

dying crank sensor stalling or dying or not starting especially when hot

bad icm hard to start or wont start or runs badly when hot usually

dyinf fuel pump can be about anything at any time, hard ot start, or running weak or missing when trying to accelerate in gear are most common issues

bad wires or plugs usually cause bucking misfiring popping when trying to accelerate in gear, and sometimes pop cough when out of gear and rev up real fast
 

·
Registered
Joined
·
175 Posts
Discussion Starter · #7 ·
remove the egr and clean carbon out of it make sure its closed/seated all the way. reinstall it with new gasket and dont plug it in, run it for a couple days without it connected to wiring and see if is better noticeably

if no good then try another map sensor and check fuel pressure at rail

also try another crank sensor or cam sensor from a known good runnign engine, this is why i keep parts like this around from engine swaps so i can try them on engines that are messing up

crank sensor can start failing when hot

so can an ICM

theres alot of possibilities here and it can be real fun to figure what part is dying.

some parts dont work right when cold and others dont work right when hot

you just have to know from experience which ones will do it when

so its fun..

usually a stuck egr will cause either hard to start or stall when fired up

bad map sensor either bad idling, or stalling out when coming to a stop in gear after having been cruising

dying crank sensor stalling or dying or not starting especially when hot

bad icm hard to start or wont start or runs badly when hot usually

dyinf fuel pump can be about anything at any time, hard ot start, or running weak or missing when trying to accelerate in gear are most common issues

bad wires or plugs usually cause bucking misfiring popping when trying to accelerate in gear, and sometimes pop cough when out of gear and rev up real fast

Well from the sound of this my fuel pump is dying? My truck usually busts right off. There has been very few times that it didn't but even then it doesn't have a problem starting. It's when i slowly accelerate that it spits, if i hotrod it, it cuts down on most of the spitting. Thanks for the info.
 

·
Registered
Joined
·
175 Posts
Discussion Starter · #8 ·
Sry for double post, is there any way to take apart the egr valve and clean it myself?
 
1 - 8 of 8 Posts
Top