S-10 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter · #1 ·
Hi,
I swapped in a 5.7L vortec EFI into a 1988 S15.
I'm having some issues I can't identify.

1: when i try and coast on the freeway (50 MPH + ) the engine starts to go into compression, and slows my truck down.
2: At exactly 67MPH I get a whistle that will get louder or quieter depending if i press down on the peddle ( Peddle makes the pitch higher if i give it more gas to go faster than 67 MPH.
3:I have a rough idle, when I sit and let my truck warm up in the morning after about 2 minutes my idle gets choppy before it stables out again. My fuel pressure is good at 60PSI.

The ECM was tuned by Blackbear, and it has some stuff deleted.
The 2 post cat O2 Sensors are deleted,
EGR is deleted,
and tuned for performance.

If I think of something else i'll update the post.
thanks for any help!
 

·
Registered
Joined
·
368 Posts
Can't help with the whistle or rough idle, but the first symptom sounds like the converter isn't unlocking when you coast as it should, leaving you basically connected directly to the trans, like a manual trans.
 

·
Registered
Joined
·
63 Posts
Discussion Starter · #3 ·
Can't help with the whistle or rough idle, but the first symptom sounds like the converter isn't unlocking when you coast as it should, leaving you basically connected directly to the trans, like a manual trans.
So likely a bad Torque converter? is there a good way to diagnose that?
thanks!
 

·
Registered
Joined
·
368 Posts
Try tapping the brake as you start "coasting". The brake switch is supposed to unlock the converter. If it continues to engine brake, that's likely the culprit.
Talk to a transmission shop before you start throwing parts at it, they may have seen it in the past and save you some money and time.
 

·
Registered
Joined
·
63 Posts
Discussion Starter · #5 ·
Try tapping the brake as you start "coasting". The brake switch is supposed to unlock the converter. If it continues to engine brake, that's likely the culprit.
Talk to a transmission shop before you start throwing parts at it, they may have seen it in the past and save you some money and time.
When I swapped in the 5.7l I also swapped in a 4l60E.
I don't remember having to put in a brake switch on the peddle anywhere, could that be my problem? (just the stock brake switch for the rear lights) I did have another guy finish up the wiring to mate the two harnesses, i'll give him a call and ask if he wired it in.
 
1 - 5 of 5 Posts
Top