S-10 Forum banner

1 - 9 of 9 Posts

·
Chrome sucks-Get over it!
Joined
·
850 Posts
Discussion Starter #1
This is a repost from another forum, but no one responded...

My A/C won't work. I just recharged my truck, and its at 45 psi on the low side. I can turn my HVAC off and on, but thats pretty much all it does. It blows air through the dash vents and the floor, but that's it.

I did some guessing about the HVAC system, and some searching and found out that the HVAC panel is vacuum powered. I am capable of replacing the hoses, but I need to know what to buy, and where all it's routed in my truck.

Thanks,
Eric
 

·
Hello there!
Joined
·
5,227 Posts
First you should check under the hood for broken hoses. From the throttle body to the driver's side of the truck there should be a small hose that runs into a check valve, from the check valve it breaks off into the vacuum ball and the other end i think goes through the firewall.
 

·
Chrome sucks-Get over it!
Joined
·
850 Posts
Discussion Starter #3
Well, my vents now work correctly, and I'm assuming my brakes will now function as well...but still no A/C and I'm hearing a clanging noise once in a while?!

Any ideas?

Thanks,
Eric
 

·
Chrome sucks-Get over it!
Joined
·
850 Posts
Discussion Starter #5
Its coming from under the hood, and it sounds like chains hitting each other...its only sometimes when I rev it...I didn't have the truck running for long enough to make it consistent though.

Eric
 

·
Chrome sucks-Get over it!
Joined
·
850 Posts
Discussion Starter #6
Even better...my F*CKIN truck sucks. I heard a noise under my hood when the truck was off...turns out there's a leak from somewhere around my compressor...I think its shot :(

I want A/C so bad but I can't afford to buy a new damn compressor.

Eric
 

·
Better post-em.
Joined
·
11,303 Posts
ahhh welcome to my hot a/c less world, hope your windows roll down. but ya ive heard that the compresors are notorios for going out like that, just like the fuel sender unit.
 

·
Chrome sucks-Get over it!
Joined
·
850 Posts
Discussion Starter #8
comics22 said:
ahhh welcome to my hot a/c less world, hope your windows roll down. but ya ive heard that the compresors are notorios for going out like that, just like the fuel sender unit.
I hear you on that, my POS truck did THAT one right after I got it. I spent 3k on my s10 with no PW/PL/etc. with 104k miles on it. 6 months after I got the truck, In a period of 10 days, I paid 97 bucks for dexcool/rad hose/etc, 600 for fuel pump/sender, and a week later 600 for a headgasket...all the while I have no damn AC to go with it! This is likely the last GM vehicle I'll buy.

Eric
 

·
Chrome sucks-Get over it!
Joined
·
850 Posts
Discussion Starter #9
Oh yeah, and I've been without AC since I got the truck, I just finally decided to refill the system and found out the compressor blows balls.

Eric
 
1 - 9 of 9 Posts
Top