S-10 Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Im working on a 1995 4.3 5 speed and this thing has me baffled! I put my scanner on it still cant figure out what the deal is. Ive been told this is a one year only comp. The issues the truck has is driving down the road and all the dummy lights start flashing and the truck dies. Sometimes it will start right back up other times it wont for hours. With the scanner on it while running all the sensors are reading screwy. Unplug the TPS MAP and ICS and the scanner still reads as if they are hooked up truck dont act any diff. (its a snap-on solus pro scanner so I know its not that) I called all the parts stores and even Chevy dealer and no one can get me the comp that is in this truck. I looked up on ebay and still can find it. The only one I found that matchs the serv number on this comp came up as a 2005 alison trans comp. WTF? A guy I know did find a reman comp with matching servi number number ordered it and when I hooked it up in the truck it wont comunicate with the scanner? Has anyone else ever had this prob or have any suggestions please I would really appritiate it. Thanks

serv number 16184738 BAAZ
 

·
i saw what you did there!
Joined
·
3,573 Posts
make sure distributor isnt shot

how sloppy is the shaft?

if its sloppy enough it will mess it all up and may not run at all any more

got this problem with a 95 tahoe 350 tbi we have right now here at our shop trying to figure out the damn thing,, same general wiring and ignition system as 4.3

after we tried new ICM, FP, and more parts

noticed it wouldnt start at all when distrib bolt is tightened, but when its loose it will fire up and runs great

but when you put into gear and try to go at all it bucks hard hops stalls every time for no damn reason,


try loosening up your distrib bolt and see if it changes anything

95 is a pain in the ass year for sure,
everything is oddball unique on in that damn year

still older tbi but newer style everything else around it,

what a mess,.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
come to find out there was bad ground in one of clips. Comp was bad but we found one through dealership in another state. thanks for your input.
 

·
Registered
Joined
·
1 Posts
Listing of commonly asked computer questions and answers and basic troubleshooting steps for major operating systems and software programs. Keep in mind that this is just a select few of our thousands of questions and answers in our database.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top