S-10 Forum banner

1 - 6 of 6 Posts

·
Drag it before you bag it
Joined
·
134 Posts
Discussion Starter #1
The other day I went to start my truck and it wouldn't start. I thought it was the battery but no, the dome light was on. the key wouldn't even make the buzzing noise. After a few times of wiggling the key the gauges came on and the buzzing noise and it started. I checked the starter it was loose so i tightened it. It ran fine for a few days then it started doing it again. But this time the radio was reset when it started. Like the battery died. I went and had it checked and it was good. They told me it could be my ignition lock. Could that drain your battery if the contacts are just touching enough to get some current? (like a short)???? My key and the ignition lock wiggle around. and i can take out the key when i turn it to accessories position. It is a very annoying problem can anyone help me???????????
 

·
Trance is what I breathe
Joined
·
926 Posts
Could be a dead spot on the starter... Do you hear a click when you turn the ignition and your lights go dim? If so it may be a dead spot in the starter... If so you can get under the truck, get something hard like a little hammer and bang on the starter a few times.
 

·
Early Member
Joined
·
3,135 Posts
If you can pull your key out with the ignition on, you need a new ignition switch.
 

·
Registered
Joined
·
6,374 Posts
make sure your grouund onb the motor to the battery is nice and tight one of the other guys had a problem like this and the grouund had come loose.. doubt its the starter... other thing do you have any play in the collumn? if so this can be the problem.. i know 94 had a first gen column and the tilt bushings tend to wear out over time causing some wieres to be pinched and giving issues like this... lift the steering wheel up and down and if it moves without using the tilt bar its prolly part of the problem.... i know i need to woerk on mine...
 

·
Drag it before you bag it
Joined
·
134 Posts
Discussion Starter #6
My steering column is nice and snug its just the key wiggles around. The lights do dim when i turn the key they almost go out. There is a click noise but it sound like its under the dash. It did it again today and i got mad and ripped my amp and underglow power wires out, and moved the battery cables around and it started right up. If there was a dead spot in the starter would the CD player reset?
 
1 - 6 of 6 Posts
Top