S-10 Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
My truck will run fine sometimes and other times it acts like it loses power and just falls on its face. If you push the gas pedal down harder it does nothing. I have replaced plugs and wires, fuel filter, fuel pump, air filter, oxygen sensor, and pcv valve. Any ideas?? Maybe the egr valve??
 

·
Registered
Joined
·
8,782 Posts
Have you checked the ICM?

Have you tested fuel pressure?

Pull the vacume line off the EGR, plug the hose, rap the top of the EGR a bit with a screwdriver or a wrench, then retest.
 

·
i saw what you did there!
Joined
·
3,573 Posts
icm is ignition control module

and they like to mess up when hot

pretty common

fuel pressure shoulkd be around 9 to 12 psi if its TBI fuel system

make sure full 12 volts to pump wire, often they fail over time and wont allow full voltage to the pump and therefore not enough fuel to TB unit

ive had to fix this many times on trucks these years and newer also.

probably about 8 or 10 now

the most recent was an 88 with 2.5L

pink wire under hood driver side, along frame to the pump wire at hanger assembly, replace it if it reads less than 12 volts at the tank connector
 

·
Registered
Joined
·
8,782 Posts
ICM can be tested at parts store, have them run test several X.....

I would look for fuel pressure to be around 12 PSI for the TBI system to work well. It will still run on lower, but it may not run as good.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
Well, I have not had a chance to check fuel pressure, but I am kind of thinking it is not a fuel pressure problem because it runs fine at wide open throttle (when the most fuel pressure is needed). Check engine light came on and code said egr circuit. The egr valve is fine and I ended up replacing the egr vacuum solenoid and it did not fix it. When I drive down the road and hold the throttle steady, it will just keep losing power. Mash the gas pedal on down and it acts like it is running out of gas. Let off the gas a second and push it again and it is fine. Anymore ideas?
 

·
Registered
Joined
·
8,782 Posts
hows the vac supply to egr sol?
 

·
Registered
Joined
·
8,782 Posts
Pull the vac line off the EGR and plug the hose. Test drive it.
 
1 - 9 of 9 Posts
Top