S-10 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
First post on s10 forum so thanks in advance for any help you can give me on this. I just picked up an 88 s10 blazer 4x4 with a 4.3 l tbi v6. The motor has 90k on it, the tb has 190k on it. I am a carb person with limited tpi experience so tbi is new to me. The truck is running very rich with a heavy gas smell from the exhaust. It also has a very high idle 2000 rpm no noticeable vac leaks. I am going to replace the water temp sensor, clean out or replace the egr, check the timing and see if there are any vac leaks I missed. Being as bad as it is I don't expect any of that to solve the problem and I have limited time to get it streetable. I do not want to drive it like it is. I suspect fuel pressure reg and tps, maybe o2 sensor also? I have no codes. If this is the case dose it make more sense for me to try to rebuild the tb and replace all the sensors and the injectors(I have never done this) or replace it with a holley 502-7? If I went with the holley would I have to bore out the manifold or will it just bolt up? Am I headed in the right direction?
 

·
Registered
Joined
·
73 Posts
my 95 4.3 tbi was doing the same, mine has a electric egr valve and it had gone bad!
try egr first, yours is a vaccum style right??
 

·
Registered
Joined
·
619 Posts
while your doing all that stuff check the fuel pressure 9-14psi
any more and you will get a bad spray and load everything up

temp sending unit might fix it, just remember there are two.... you want to replace the on in the middle of the intake

EGR clean out and check operation, that helps alot.

20 bucks roundabouts for an 02 sensor, i doubt its causing your problem but after you get it fixed it wouldn't hurt, running rich will really foul out the o2 sensor
 

·
No it's not riced.
Joined
·
184 Posts
i got an 88 blazer with the 4.3 too and it runs damn rich... i mean u can get some exhaust water and light it on fire so ya its rich.. mine is because the o2 sensor is nothing more than a shrivelled piece of plastic causin the comp to default to a rich mix, so check that o2 sensor for actual physical damage.
 
1 - 4 of 4 Posts
Top