S-10 Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hello all...I'm new to the forum and had a question..
I have been doing some reading on all the different places to
open up the air flow through the engine. Has anyone seen or
done a restrictor plate removal off of the tb? I was just wondering if it will hurt or void the warrenty on the truck? Any suggestions?? Thanks

xbAndiTx
:scary:
 

·
Registered
Joined
·
1,329 Posts
First off this is not a restrictor, its a deflector. It is there to get a turbulance created for the mixing of incoming EGR gases. If you remove it it will run slighty different in the lower rpm ranges( A little surgie, but not bad) and at higher rpms it'll run much smoother and make some more power, but not much. If they find that you have removed it, the TBI unit and EGR valve will not be covered, but everything else will.Its entirely up to you. I dont have the deflector myself, along with a bored MAF, and run no egr, but the valve is in place. All together Ive made roughly 7-10 H.P. with the mods.
 

·
want my #... 911 beotch!!
Joined
·
2,186 Posts
964pt3 said:
I dont have the deflector myself, along with a bored MAF, and run no egr, but the valve is in place. All together Ive made roughly 7-10 H.P. with the mods.
if it is not too much trouble, could you go into a little more detail as to how to go about doing the mods you talked about? thanks.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
MightyMouseJ5 said:


if it is not too much trouble, could you go into a little more detail as to how to go about doing the mods you talked about? thanks.
Thats what i was thinking too...also..what do you mean by a bored maf? is it aftermarket..like a granatelli..or did you mod it yourself? thanks!!
 

·
Registered
Joined
·
1,329 Posts
Check out www.sshotrods.com, John has Pics of a MAF mod along with the IAT relocator I did. The difference in the MAF mod he has posted and what I have is the fact I'm a machinist and along with the screen and center bar removal, I bored my MAF to the exact size as the TBI inlet. He also has the deflector removal, but I dont like the way they did it. I just took off my TBI unit and drilled the 2 rivets that hold it in, this way if you dont like, you can reinstall the plate with a rivet gun. And when you remove the plate this way you need to plug the 2 holes up or it will never idle. So what I did after I took it off was to use 2 screws and nuts to plug the holes off. Use screws that fit somewhat tight in the holes, then with a set of pliers, damage the screw that projects beyong the nut so they cant fall off and get into the cylinders. Now the EGR block off, again I machined a custom fitting so that the tube looks connected , but has no hole in it. Thus no EGR gases can get in. I left the valve in because the OBD2 will not allow you to disconnect it without throwing a code.

Oh, by the way I wouldnt give you a nickel for a Grant unit. Yes its bigger in internal bore size, but bigger than the TBI unit is, so it cant do anymore than a modified one like mine. A bigger hole in the MAF wont allow more air in, it can only allow what the TBI inlet size has. And for advanced eletronics, BAH HUMBUG, the computer can only read what it is programmed for, nothing else, how can it be faster, yes it may have more sensitive electronics therefore at MOST a few milliseconds faster. Guess what, you could never tell. For the $300 the Grant wants I would suggest a E-Ram unit for $300, you will gain 10 H.P. with it.
 

·
want my #... 911 beotch!!
Joined
·
2,186 Posts
havin some troubles

well i took out the plate on in my throttle body. it idles a little different. when my truck is in park and i blip the throttle, the rmps go up then when they come back down my engine almost stops, then it idles rough struggling to keep going for a few seconds, then it levels off and is ok. when i start it and put it in reverse it hesitates. then i select drive and it runs rough for a few seconds and hesitates some more. then it is ok. what should i do? any ideas? ill try to IM you when i catch ya on. thanks.
 

·
Registered
Joined
·
1,329 Posts
When you did it I'm assuming that you plugged the 2 larger holes which the rivets were in. By chance did you block of the small center hole, this one needs to be there for idling purposes and if you plugged that one it is the culprit. Some people including myself have had problems with this mod not being quite right as far as running, thats why I said to drill the rivets out in case it didnt go right so you could reinstall it. My first attempt at this was when it was new 6 years ago, it didnt run right, had surging problems. This mod shouldnt be a problem as far as idle speeds unless either you dont block the rivet holes or plug the center idle hole, there should be no change at idle. And at first when I did it again it took the computer a few hours of running to get the mix at low rpm's right. Let me know, cant guarrentee this mod for everyone.

Your sig says that you have flowmasters to annoy me? I got grey hair and run and ultraflow with a turn down, dont bother me:D
 

·
want my #... 911 beotch!!
Joined
·
2,186 Posts
964pt3 said:

Your sig says that you have flowmasters to annoy me? I got grey hair and run and ultraflow with a turn down, dont bother me:D
it is for the anal people to be bothered by, not the cool people like yourself!:) thanks for the tip. the rough running comes and goes. i did plug the two big holes, left the idle hole alone, and drilled out the rivets. so if i give the computer time it might settle down?
 
Joined
·
39 Posts
how did you plug the holes??
 

·
2001 Fire Starter
Joined
·
699 Posts
This is what I did.....

I took the plate out and popped the rivets out with a hole punch. and the reflector popped right off. I then took two small screws and put them into the hole, and put little nuts on theother side and tighten them down has hard as I could and striped the threads so that they couldn't back out. I didn't have any problems with mine.....and the response is a lot better know, thats about all I noticed from it
 

·
Registered Abuser
Joined
·
107 Posts
i just put pop rivets in the holes and clipped the back off the rivets and ground it clean, has an nice low profile on the throttle blade. Looks stock too
 
1 - 16 of 16 Posts
Top