S-10 Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
73 Posts
Discussion Starter #1
if i put 3 inch blocks on my ZQ8 ,, can i use the stock bilstien shocks?
 

·
Red X = Pure Sex!
Joined
·
3,366 Posts
Twin-10s said:
the stock shocks will be fine. you need to remove the rear bumpstops. that is ussually the problem. blocks do not change the travel in the shocks at all.
:stupid:
 

·
Xtreme Dreams..
Joined
·
1,939 Posts
I'm bagged with my stock shocks, and 4" blocks and I have no problems. I guess the bags help...
 

·
Registered
Joined
·
610 Posts
i also have 3 inch angled belltech blocks, i removed the bump stops and have no problem, the reason it rides like sh*t is because your bump stops are contstant bottoming out...
 

·
Registered
Joined
·
718 Posts
SSVortec said:
i also have 3 inch angled belltech blocks, i removed the bump stops and have no problem, the reason it rides like sh*t is because your bump stops are contstant bottoming out...
Did you remove ALL of the bumpstops? the guy that installed mine only cut a little bit off of the bumpstops, at first it only hit every now and then, now about 4,000 miles later....it bottoms out very easy! should i have the rest of the bumpstops and the brackets cut off or just get a little bit more cut off? thanks....
 

·
Registered
Joined
·
1,917 Posts
Yes cut off the entire bracket and it will ride smoother.
 

·
Registered
Joined
·
610 Posts
both of the brackets on the rear end, cut them off!!! lol, its very easy, you can do it your self with an angle grinder
 

·
Registered
Joined
·
718 Posts
01_ZQ8_S-10 said:
Yes cut off the entire bracket and it will ride smoother.
the entire bracket and all of the bumpstop?? or just the bracket?
 

·
Registered
Joined
·
247 Posts
Yeah same problem here. Going to have to cut the bumpstop brackets off. Every little bump hits hard. Maybe it's a good thing though, keeps me from speeding LOL. I will be cutting my brackets off soon, and hopefully it will fix the problem.
 

·
Registered
Joined
·
610 Posts
yea, the braket is waht holds the stop on the truck, be sure to spray some rustoleum on there are you grind it all off to prevent rust on the frame
 

·
420
Joined
·
676 Posts
Xtreme_Girl_25 said:
Did you remove ALL of the bumpstops? the guy that installed mine only cut a little bit off of the bumpstops, at first it only hit every now and then, now about 4,000 miles later....it bottoms out very easy! should i have the rest of the bumpstops and the brackets cut off or just get a little bit more cut off? thanks....
Damn you've gone 4,000 miles without cutting that bracket out? i only went 30 miles and said damn this sucks. So i cut um out and haven't bottomed out since. Just cut the whole thing out...
 
1 - 16 of 16 Posts
Top