S-10 Forum banner

1 - 15 of 15 Posts

·
Banned
Joined
·
770 Posts
Discussion Starter #1
my dad has a 2000 xtreme he bought used and yesterday
he tells me he "hates this piece of shit truck" I asked why and
he said because somethings always rattling or making noise

I drive over to his house and take a listen - when he gets
the truck started, he goes listen...... hits the gas and from in the dash came this bzzzzzzzzzzzzzzzzzzzzzzzzz sound, the tone would change along with the engine....I told him it sounded like a noisy tach or something, I know since the tachs are electric it could be some gears grinding or something, anyone else heard of this or had similar problems?
 

·
Chrome is Gay
Joined
·
3,693 Posts
Tachs are electric? I've never messed with one one on s-10's but it should just be a cable coming off the trans and going through the firewall and into the dash
 

·
Banned
Joined
·
770 Posts
Discussion Starter #4
It's definitly not alternator noise, it sounds like its coming right from the gauge cluster and the sound it makes flos along with the tach movement
 

·
At least it turns fast
Joined
·
1,190 Posts
German_Xtreme said:
Tachs are electric? I've never messed with one one on s-10's but it should just be a cable coming off the trans and going through the firewall and into the dash
Thats the speedometer cable... and we don't have one of those either, we have a VSS (not sure how if and how long ago they used cables on dimes) Tach's are always electric. My tach on my nova is electric.
 

·
ask me about my crabs
Joined
·
81 Posts
yeah the tachs connect into the distributor and the speedo goes back to he transmission or transfer case. I know this case mine constnly comes out while i am on the freeway and have no idea what speed i am going
 

·
Banned
Joined
·
770 Posts
Discussion Starter #7
so nobody has ever heard this noise in thier xtreme?

my truck is a 97 and the only problem i had was something the dealer called a "drac" and what that does is control all the eltric stuff in the truck - transmission, guages, ect - my tranny was slipping b/c it didnt know when to shift and the gas guage was all the way down like it was busted - other than that i could not have a clue what else would be makin those noises
 

·
An Accredited Institution
Joined
·
29 Posts
I've got a 2000 4.3 and my PCV valve rattles like crazy at idle. I even went to the Chevy dealer and picked up a new AC Delco and it rattles worse than the old one.

I've tried greasing the inside of the valve with wheel bearing grease but that did not help. Must be a poor design.

You might try un-hooking your PCV valve to see if that takes care of your rattle. I had an idea to just take the thing off permantly but was advised against it since it removes a lot of the blow-by gases that would otherwise cause the oil to get nasty prematurely.
 

·
Chrome is Gay
Joined
·
3,693 Posts
03zq8 said:
Thats the speedometer cable... and we don't have one of those either, we have a VSS (not sure how if and how long ago they used cables on dimes) Tach's are always electric. My tach on my nova is electric.

Thats what I get for posting when I'm half asleep. I was thinkin one and talking about the other. I had no ideal about the VSS though, got any more info?
 

·
Registered
Joined
·
229 Posts
I HEAR IT IN MINE TOO.....I thought I was the only one, so I didn't want to say anything. It's like something inside the dash is rattling....like a tap..tap...tap....but really fast. Yeah...if thats what your hearing then we have the same problem. I've got an 01 x....so when you figure out what it is...then let me know!
 

·
Banned
Joined
·
770 Posts
Discussion Starter #11
xtreme2299 said:
I HEAR IT IN MINE TOO.....I thought I was the only one, so I didn't want to say anything. It's like something inside the dash is rattling....like a tap..tap...tap....but really fast. Yeah...if thats what your hearing then we have the same problem. I've got an 01 x....so when you figure out what it is...then let me know!
you got it!, that is if my dad finds the problem, i was just posting on here for help to try and help him, mines a 97 and it dosent do anything like that :smoke:
 

·
Registered
Joined
·
229 Posts
Thats what I thought it could be...that what it sounds like. But everything still works fine. (as far as I could tell)....I have a real problem with getting things back together the way they came off. So I was hoping to take the easy way out and find out the problem.
 

·
Banned
Joined
·
770 Posts
Discussion Starter #14
Its my dads, not mine, if I can .....sometime thisweekend, id do it for him, if it was my truck id do it too, but I figured someone on here has had the problem and might have a slution - I was just tring to find help here, sorry
 

·
The Dave Inc.
Joined
·
11,720 Posts
my grandmas accord did that crazy buzzing n shit and it was a relay gone bad
 
1 - 15 of 15 Posts
Top