S-10 Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I have a 2000 s10 2.2 auto ext cab. I'm getting 14 mpg on the highway:rant:..I have changed the cat,plugs,plugwires,temp sensor, flushed, checked vacuums, I'm going to reinstall my factory air box (I have a k&n cold air now) and fuel filter. Also when I am at highway speeds sometimes its like I take my foot off the gas and it will drop 10-15 MPH...I'm at my witts end..any ideas?
Thanks ahead for any help
 

·
Registered
Joined
·
375 Posts
If it slows down quickly check your brakes. Maybe something sticking on these trucks aren't all that easy on gas either. Any codes in it ? If you can get your hands on a scan tool that would be a good place to start
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Thanks for the reply, Its throwing no codes. Only code it threw before was a temp sensor which I replaced. Wheels seem to turn free. I know I shouldn't get great but I should get more than 14 on the hwy...I get about 35 miles on 1/8 of a tank it has the 19 gallon tank
 

·
It's mostly BS
Joined
·
2,940 Posts
Thanks for the reply, Its throwing no codes. Only code it threw before was a temp sensor which I replaced. Wheels seem to turn free. I know I shouldn't get great but I should get more than 14 on the hwy...I get about 35 miles on 1/8 of a tank it has the 19 gallon tank
Tell us that's not how you are calculating your fuel efficiency. In case you are, try it this way:

http://www.fueleconomy.gov/mpg/MPG.do?action=calcMPG
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
I fill up, then I drive until 1/2 until almost empty. I fill up again just as before I take the miles and divide it by the gallons
 
1 - 6 of 6 Posts
Top