S-10 Forum banner

21 - 40 of 56 Posts

·
Registered
Joined
·
127 Posts
Discussion Starter #21
So I unplugged the vacuum line that runs straight from the tbi to the vacuum control valve. Idle raised a bit and it's not as loppy, but keep in mind I've had the egr disconnected. Imma see how it does. Possible a new vacuum valve


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
127 Posts
Discussion Starter #22
Q ImageUploadedByAG Free1434228635.690532.jpg ImageUploadedByAG Free1434228655.189322.jpg

Changing plugs wires cap and rotor. Bent cap posts and pulled 3 wire connections out with ease when I removed the wire. Also one plug is chipped right at the center electrode. I can't find any charts though


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
127 Posts
Discussion Starter #23
Another problem. In park or neutral I can ref my truck shy of 7k rpm. With the peddle to the floor overdrive or not my transmission shits around 4k, it won't go above 4k. Now I can drop it into drive 2 or 1 and get it all the way to red line. In drive 2 at 5k I'm hitting over 70mph. But even in d or od if you put the peddle to the floor it should redline before it shifts correct?

Also. I took the filter out the back of the electronic vacuum valve. Now if I've got my egr hooked and plug the tbi line into it the engine stalls immediately. If I unhook the egr all it does is idle a couple hundred rpm slower. Is that normal? At the moment The tbi line that goes to the valve is open in the engine bay, truck is idling warm at 800


Sent from AutoGuide.com Free Appah
 

·
Registered
Joined
·
127 Posts
Discussion Starter #24
I just got done. I advanced the timing and backed it off. I've still got slight starter lag. But now at idle, if I lay on the throttle the injectors pulse for a split second like tsh tsh tsh and straighten out. But also playing with the timing. I never heard spark knock once, and I advanced it and retarded it until it cut off. Only problem was I unplugged the est and whenever I would adjust the timing the engine would speed way up for about 10 seconds both advancing and retarding


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
127 Posts
Discussion Starter #25
So I timed it off vacuum. Max i was getting was about 18 inches. I backed it off to 16.5. And every time I lock the distributor down it drops back don't to 15 inches. Now it's reading about 13.5-14. So needless to say I can't time it. I drove 20 miles and burnt a quarter tank of gas. Imma throw a new distributor in it this weekend, if it doesn't fix much. Time for the 3.4. I could have already done the swap with me trying to fix the 2.8


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
127 Posts
Discussion Starter #26
I am postulating that the distributor internals are shot. When I tighten it it advances the timing. I can either purposely set the Timing low and hope it messes it up enough to run right or just get a new dizzy this weekend. Either way it's got some serious detonation between 900 and 1400 rpm. Sounds like backfire out the exhuast(which I know it's not)


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
127 Posts
Discussion Starter #27
Another question. When I tighten the hold down bold, I tighten it until I can't move the wrench anymore, could I be over tightening it moving the gear teeth slightly away from each other. I feel like I answered my own question, but comments would be helpful


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
855 Posts
Hmmmm...not sure what to tell you. This is one of those situations where knowing if the ECM is throwing a code and/or hooking up something to view live sensor data would help.

I know on my truck, the distributor would shift slightly when tightened down.

Are you sure your not 180 out?
 

·
Registered
Joined
·
127 Posts
Discussion Starter #29
So guess what. Brand new set of spark plug wire from advance. Apparently the last 2 days I've been running on 5 cylinders. So I won't be buying cables from them anymore. Put my old one on and it runs hell of a lot better. Still slight ping. Imma back of the timing slightly now. Also adjusted my tv cable and it shifts like its suppose to, at least I can hit 5500 rpm now. Nah I've always been careful putting the dizzy back in, that was the one part nobody could touch.
And it doesn't throw codes anymore since I blew out the vacuum valve for the egr.

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
855 Posts
That's awesome.
 

·
Registered
Joined
·
127 Posts
Discussion Starter #31
For the most part it's running better. Still have some starter drag. But it's not knocking of half 87 and half 92 in the tank. I'll have to further adjust it once I get a vacuum gauge


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
855 Posts
I hope you don't mean that you are going to adjust the timing.

The ecm expects the initial timing to be at 10 degrees. All of it's timing is based on that.
 

·
Registered
Joined
·
127 Posts
Discussion Starter #36
So it's still at 10 degrees. So it's not jumping timing, I'll test the ignition components with an ohm meter tomorrow. For some reason I think it's fuel related. Still having the injectors pulse if you suddenly open the throttle
And it's not throwing codes

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
127 Posts
Discussion Starter #37
So if also got a new distributor. Is there anyway to verify the distributors inner components are good without taking it out of the engine? If it's good imma return the distributor I bought. Also is it normal to be able to move the rotor button slightly when the cap is off


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
127 Posts
Discussion Starter #40
So I'm sure I figured out what it was. I had a major vacuum leak at the tbi test port. Got that straightened out, changed all the vacuum hoses, fuel filter. So I'll be test driving soon. Also got some blue led driving lights hooked up, and some off-road lights


Sent from AutoGuide.com Free App
 
21 - 40 of 56 Posts
About this Discussion
55 Replies
4 Participants
S10tahoe28
S-10 Forum
S10forum is the community to discuss the S-Series, Chevrolet Colorado and GMC Canyon. Join to discuss rebuilds, modifications, tech articles and more!
Full Forum Listing
Top