S-10 Forum banner

1 - 6 of 6 Posts

·
V8 needin' member
Joined
·
424 Posts
Discussion Starter #1
i have a 85 s10 with a carb'd 2.8 in it and the problem is i idle high.... liek 2300 most of the time...could anybody tell me what is goin on i tried to adjsut my carb and that didnt help
 

·
Registered
Joined
·
1 Posts
What you have is a vacuum leak. Knowing the amount of vacuum lines that are on an old S-10 2.8, it is a safe bet one of them is leaking. If not all of them.
 

·
V8 needin' member
Joined
·
424 Posts
Discussion Starter #3
so what u r telling me is that i am ****ed as far as finding the leak or is there a way to isolate it... it idles real high(2200) for a while then occassionallly after a while itll drop down to about 1000 which is ok?:werd:
 

·
Registered
Joined
·
176 Posts
yor chocke may be sticking also but its pretty easy to find a vacum leake
. but its moer then likely that old pos choke
i once had the same problem
.to find vacume leak get spray bottle fill with soapy water spray on one line at a time . if you see no air bubbles its not that line try the next
 

·
V8 needin' member
Joined
·
424 Posts
Discussion Starter #5
ok cooll thanks man yeah like i sprayed the carb down with carb cleaner a while ago and it stopped doin it so im thinkin it might be the choke.... im gonna check those hoses too
thanks
russ
 

·
V8 needin' member
Joined
·
424 Posts
Discussion Starter #6
damn it keeps getting worse im idling around 2600rpm now... i checked my lines and found one that was torn so i replaced it and it still didnt fix it...still need to check the choke out
 
1 - 6 of 6 Posts
Top