S-10 Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter #1
How do I get this thing open? I just wanted to plug it in and now its so cold out I don't want to but must change cause I need it tomorrow. Tell me its easy!
 

·
Registered
Joined
·
98 Posts
I was able to reach in through the gap between the hood and the grille with a socket and remove the bolts that hold the latch on. That was after messing with it for like an hour with screwdrivers, etc.
 

·
Registered
Joined
·
51 Posts
Discussion Starter #4
Well, I took a look before it got dark and then again with a flashlight and can't tell what I'm looking at but its like a million below out and that's screwing me up more than anything. But I'm assuming your talking about the little hole at the top in the middle? Theres really only one way I can go about it but I'll see tomorrow. Maybe I'll take a few pics just to show but think I have a handle on it. Or better yet if someone had pics that would help. I'm thinking my screwdriver was to short when tried before.
 

·
Registered
Joined
·
30 Posts
Well, I took a look before it got dark and then again with a flashlight and can't tell what I'm looking at but its like a million below out and that's screwing me up more than anything. But I'm assuming your talking about the little hole at the top in the middle? Theres really only one way I can go about it but I'll see tomorrow. Maybe I'll take a few pics just to show but think I have a handle on it. Or better yet if someone had pics that would help. I'm thinking my screwdriver was to short when tried before.
 

·
Registered
Joined
·
30 Posts
Try a coat hanger bend the front part almost 180 deg. then bend again about 5 inches back w/ a 90 degree, you need to get behind the front part that you see,on you might get a hold of lever, pull to the right.as you get a hold on it...hope this helps peace Dave...
 

·
Registered
Joined
·
51 Posts
Discussion Starter #7
Ok now I'm stumped. I had to destroy my bug deflector to get to it but then I find my cable isn't broken but has come out of place. So after many screw drivers, needle nose pliers etc... I get it back on and it won't budge. So now its soaking in lube and I hope it works. I did have a hammer on the end of more than one screw driver and I don't think it moved at all. Even had a big pick tool hooked into it and couldn't move than either.
 

·
Registered
Joined
·
51 Posts
Discussion Starter #8
Well, it took three days and half a can of lube and got it open. The cable came out of the spring and the cable end slid to the end but didn't come off. I left it on for now but put a small cable clip on it and seems to work so far.
 
1 - 8 of 8 Posts
Top