S-10 Forum banner

1 - 5 of 5 Posts

·
Premium Member
Joined
·
46 Posts
Discussion Starter #1
Took truck for a ride this morning and noticed temp super high. Took thermostat out and watched coolant flow through radiator. Seems to be flowing well but truck still climbing in temp. Also after removing thermostat ran truck and the pressure in upper hose was crazy high....almost like stuck thermostat but i didnt have one in there. I put new head gaskets on truck about a year ago when I did conversion but I am leaning towards bad head gasket....any ideas?
 

·
Premium Member
Joined
·
46 Posts
Discussion Starter #4
Did pressure check on coolant and it only dropped like .5 over 6 minutes. I am not sure if its suppose to hold forever, for a bad head gasket I would had thought it would drop more and quicker.
 

·
Registered
Joined
·
143 Posts
The first thing I would do is check the temp of the engine with a temp gun. It could just be a faulty gauge. It could also simply be air in the system. If the coolant system pressure test said it was leaking air then that would make sense. It needs to be 100% sealed or it will let air in the system.

Make sure you do the compression test to check for a bad head gasket. You should also check your oil for coolant and check your coolant for oil. Oil in the radiator would usually rise up under the radiator cap.

It shouldn't overheat or even get up to regular operating temperature with the thermostat out. I would replace it for safe measure.

Make sure all hoses are clamped down and there aren't any leaks anywhere.

That's all I got for now. I'm not the most experienced here so anyone correct me if I'm wrong.

Good luck!
 
1 - 5 of 5 Posts
Top