S-10 Forum banner

Discussions Showcase Albums Media Media Comments Tags

1-5 of 5 Results
  1. S10 / Sonoma
    Automatic 1997 GMC Sonoma 4.3L, ZR2 151,000 miles It was running seemingly fine last time I drove it. It was parked for about a week, nothing out of the ordinary. I went to check the fluids. Upon noticing it was drinking coolant I went to start it to get a better fill there. That's when I...
  2. Sound and Security
    So I let my brother us my truck. And the door latch stuck and he couldn't shut the door. Or didn't know how to fix it. Anyways he just left the door barely open over night Without telling me. And when I got out the next morning my hazard/ blinker lights in front and back were blinking and...
  3. 262ci Forum (4.3)
    Hi all, I am writing here because I have a problem with my 94 vortec 4.3 tbi blazer s10, I have ignition and gas but it won't start, it just makes a flame explosion when I turn on the throttle. the spark is blue so ok ignition order ok crankshaft and ignition head 1st cylinder ok coil ok icm...
  4. ZR2 - BlaZeR2 - Highrider
    Okay so I got a 2001 S10 zr2. V6 Vortec 4.3L. August of last year, she started overheating then smoking. No milky oil. No smoke from the exhaust. She set for a few months without being started. Got to looking about a month ago, radiator hose had a hole. Replaced it. I'm thinking that was the...
  5. 262ci Forum (4.3)
    Was backfiring and would not stay running , had it towed home and it sat for roughly 6 months now will not start at all. Any suggestions would be greatly appreciated, I hope it's nothing too serious
1-5 of 5 Results
Top