S-10 Forum banner

Discussions Showcase Albums Media Media Comments Tags

1-9 of 9 Results
  1. S10 / Sonoma
    Hello, My 2002 4.3 95,000 miles runs like a champ, I've done a ton of work to it. Just came back from a trip that added 1200 miles. Issue I still have with it, I often need to crank it twice to start after its sat overnight. I can hear the fuel pump kick on and the fuel filter has been...
  2. S10 / Sonoma
    Hi all, So my 2002 v6 RWD was having some issues starting. The battery is new, the alternator is fine. I would turn the key and it would just turn and turn and tun and eventually start, caugh a bit, then run fine. Ocassionally while at a light the idle would drop and sometimes stall. I thought...
  3. S10 / Sonoma
    My 2002 2WD was having some really strange starting and electrical issues over the last week. It would happen randomly with no pattern. You could turn the key and the engine would turn like it wanted to start, if you gassed it it would start, then as soon as you let your foot off the gas it...
  4. Xtreme / ZQ8
    I'm new to this site so don't know if I'm doing this right but I have a 2000 S10 Xtreme with 4.3L. the other week I changed the fuel pump due to hard starting and low fuel pressure. The truck ran fine for about a week then last weekend it would turn over but would not start. Checked fuel...
  5. S10 / S15
    While cranking it pauses for maybe 1/2 a second and then continues to crank, so far I’ve cleaned up both the engine and frame ground and I have keeping an eye on my coolant to see if I have a leak into a cylinder and I don’t. And I have also done the ignition cylinder. This weekend I and getting...
  6. Electrical / Lighting
    I got this truck earlier this year, it's my first car so I'm not sure how to fix a lot of things but as time goes on I'm learning, it was starting no problem used to start every try, but it's been sitting a while as I have been working on it, it had been in a light front end collision and the...
  7. 2.2L - 2nd gen 4-banging
    I have a 94 2.2l single cab for years I've occasionally had to wiggle the column while in park to start my truck. Last year I swapped my junk 4L60E for a NV1500 5 speed without swapping the column it still had the issue but not as apparent. About 3 weeks ago my oil pump went bad and the motor...
  8. S10 / Sonoma
    I just bought a 98 s10 from a guy who said it ran, and I fixed a few broken wires on the plug BY the ecm. I can’t get the key to a tire the starter, but I can do it manually by jumping the solenoid. The fuel pump does not come on, and the only thing on the gauges now is service engine soon, with...
  9. 262ci Forum (4.3)
    Hey guys so i just put in a new distributor and went through the whole process top dead center everything and it turns over and backfires firing order everything is correct. any ideas
1-9 of 9 Results
Top